summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/tprint
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/tprint')
-rw-r--r--app-misc/tprint/Manifest1
-rw-r--r--app-misc/tprint/metadata.xml11
-rw-r--r--app-misc/tprint/tprint-1.1.0-r1.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/tprint/Manifest b/app-misc/tprint/Manifest
new file mode 100644
index 000000000000..b8f680f4c3d8
--- /dev/null
+++ b/app-misc/tprint/Manifest
@@ -0,0 +1 @@
+DIST tprint-1.1.0.tar.gz 14089 SHA256 1faec152e3cad3fd448ab082c1a69b8eca718b94394b7f317fe153783616da75 SHA512 828135ba52a163b00257e243e683f0f01b3a47b161785c70aa2b43f227859a6a4e629687d07190c42941ab03012d6bb1eddeb3767f177af6302a873cb7713831 WHIRLPOOL d94e33e769fa5762cb742d37fc4a29eb882344605c5a4a4250dcbb616930b6a91bb6bb67fb32112cfc5641500ffaa09a4542f927ba94696cd4b9844739a53c93
diff --git a/app-misc/tprint/metadata.xml b/app-misc/tprint/metadata.xml
new file mode 100644
index 000000000000..f3fda2e81bac
--- /dev/null
+++ b/app-misc/tprint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>The Transparent Print utility program for Linux. Provides an easy way to transparently print to serial terminals that have printers attached.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tprint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/tprint/tprint-1.1.0-r1.ebuild b/app-misc/tprint/tprint-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..0030bededf75
--- /dev/null
+++ b/app-misc/tprint/tprint-1.1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Transparent Print Utility for terminals"
+HOMEPAGE="http://sourceforge.net/projects/tprint/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's:cc:$(CC):g' \
+ -e 's:-g -O2:$(CFLAGS) $(LDFLAGS):g' \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ insinto /etc/tprint
+ doins tprint.conf
+ dobin tprint
+
+ dodoc INSTALL README
+}