summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/slmon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/slmon')
-rw-r--r--app-misc/slmon/Manifest1
-rw-r--r--app-misc/slmon/files/slmon-0.5.13-invalid-free.patch18
-rw-r--r--app-misc/slmon/files/slmon-0.5.13-make-382.patch11
-rw-r--r--app-misc/slmon/metadata.xml10
-rw-r--r--app-misc/slmon/slmon-0.5.13.ebuild42
5 files changed, 82 insertions, 0 deletions
diff --git a/app-misc/slmon/Manifest b/app-misc/slmon/Manifest
new file mode 100644
index 000000000000..da3adfdedfab
--- /dev/null
+++ b/app-misc/slmon/Manifest
@@ -0,0 +1 @@
+DIST slmon-0.5.13.tar.gz 103826 SHA256 dc38740e4e0cccb86ccf76aaad5734d7d1e42e144615ee09bc8c8c9290110b28 SHA512 84bf1e3eda9c05c7029630802b6853cba1c1220fd210c2a8f26f6ffafff3aa5a8bf9945b74ca508fbf4a9038b5df26ebed529d6377fab1df4dd778cccfd74f75 WHIRLPOOL 7b4f9b081737355dd7e0aa96da2be8c8bf12fd951487851c432c63131003f7ab1b93a2bad5206d9edf8b1ad7aca553885b04942ea30c570ca68680afb094fc1c
diff --git a/app-misc/slmon/files/slmon-0.5.13-invalid-free.patch b/app-misc/slmon/files/slmon-0.5.13-invalid-free.patch
new file mode 100644
index 000000000000..d7b0e24e07d9
--- /dev/null
+++ b/app-misc/slmon/files/slmon-0.5.13-invalid-free.patch
@@ -0,0 +1,18 @@
+http://bugs.gentoo.org/151293
+
+--- rc.c
++++ rc.c
+@@ -177,9 +177,10 @@
+ char *home, dotrc[1024] = { 0 };
+
+ home = getenv("HOME");
+- strcpy(dotrc, home);
+- strcat(dotrc, "/.slmonrc");
+- free(home);
++ if ( home != NULL ) {
++ strcpy(dotrc, home);
++ strcat(dotrc, "/.slmonrc");
++ }
+
+ if ((f = fopen("/etc/slmonrc", "r")) != NULL) {
+ slmon_conf_parse(f);
diff --git a/app-misc/slmon/files/slmon-0.5.13-make-382.patch b/app-misc/slmon/files/slmon-0.5.13-make-382.patch
new file mode 100644
index 000000000000..bb128f5803e6
--- /dev/null
+++ b/app-misc/slmon/files/slmon-0.5.13-make-382.patch
@@ -0,0 +1,11 @@
+http://bugs.gentoo.org/337403
+
+--- Makefile.am
++++ Makefile.am
+@@ -15,5 +15,5 @@
+ #slmon_LDFLAGS = `libgtop-config --cflags --libs`
+
+ release:
+- $(MAKE) dist distdir=$(PACKAGE)-$(VERSION)
++ $(MAKE) dist distdir=$(PACKAGE)-$(VERSION)
+
diff --git a/app-misc/slmon/metadata.xml b/app-misc/slmon/metadata.xml
new file mode 100644
index 000000000000..076e04f24c49
--- /dev/null
+++ b/app-misc/slmon/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">slmon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/slmon/slmon-0.5.13.ebuild b/app-misc/slmon/slmon-0.5.13.ebuild
new file mode 100644
index 000000000000..a667ab05b20e
--- /dev/null
+++ b/app-misc/slmon/slmon-0.5.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Colored text-based system performance monitor"
+HOMEPAGE="http://slmon.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/slang
+ gnome-base/libgtop
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make-382.patch \
+ "${FILESDIR}"/${P}-invalid-free.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README slmonrc TODO
+ dohtml *.html
+}