summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/ofl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/ofl')
-rw-r--r--app-misc/ofl/Manifest1
-rw-r--r--app-misc/ofl/metadata.xml8
-rw-r--r--app-misc/ofl/ofl-20110721.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/ofl/Manifest b/app-misc/ofl/Manifest
new file mode 100644
index 000000000000..8b00f18e65f3
--- /dev/null
+++ b/app-misc/ofl/Manifest
@@ -0,0 +1 @@
+DIST hxtools-20110721.tar.xz 270020 SHA256 5f5642c75f94b207fa32088bdf73429a6b447af2a81b139d977435fbb2c32eed SHA512 e3dcd6b1add6824ee38ed140a6c422315afc7cec5ebd352c684c506ef25638885393b2dff3582c317862a6ae8de97105abf95b3fc16832d3247f93b2c7283c26 WHIRLPOOL 0c36c7b3c618ef3c51a0dec926536f2a8d07259108f99dde265a4032b802331b4f98f1682d184ea68cb38c127157b72dbdf5df06c2967352dd1488c1f8a6e250
diff --git a/app-misc/ofl/metadata.xml b/app-misc/ofl/metadata.xml
new file mode 100644
index 000000000000..335b9b4cce4d
--- /dev/null
+++ b/app-misc/ofl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mattst88@gentoo.org</email>
+ <name>Matt Turner</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-misc/ofl/ofl-20110721.ebuild b/app-misc/ofl/ofl-20110721.ebuild
new file mode 100644
index 000000000000..193ba1f2dbba
--- /dev/null
+++ b/app-misc/ofl/ofl-20110721.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Open file lister (replaces fuser and lsof -m)"
+HOMEPAGE="http://jengelh.medozas.de/projects/hxtools/"
+SRC_URI="http://jftp.medozas.de/hxtools/hxtools-${PV}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=sys-libs/libhx-3.4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/hxtools-${PV}
+
+src_configure() {
+ # We're just building a single utility. Don't bother
+ # with the build system.
+ :
+}
+
+src_compile() {
+ CC=$(tc-getCC) CFLAGS=${CFLAGS} LDLIBS="-lHX" \
+ emake V=1 -C sadmin ofl
+}
+
+src_install() {
+ dobin sadmin/ofl
+ doman doc/ofl.1
+}