summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-18 18:04:25 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-18 18:04:41 -0800
commite9efe4b6664420c395fcecbd3a07887c2e367da4 (patch)
tree18235f7fe2d1843520ae0b79bdc315d608ee9906 /app-misc/jq/jq-1.6-r3.ebuild
parentnet-libs/libnfsidmap: arm64 stable (bug #700444) (diff)
downloadgentoo-e9efe4b6664420c395fcecbd3a07887c2e367da4.tar.gz
gentoo-e9efe4b6664420c395fcecbd3a07887c2e367da4.tar.bz2
gentoo-e9efe4b6664420c395fcecbd3a07887c2e367da4.zip
app-misc/jq-1.6-r3: output the testsuite log if tests fail (#675510)
Since I can't locally reproduce bug #675510, and the test suite doesn't output the failure by default I am going to close the bug by now. If someone can reproduce it, it should have the failures attached. Closes: https://bugs.gentoo.org/675510 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/jq/jq-1.6-r3.ebuild')
-rw-r--r--app-misc/jq/jq-1.6-r3.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/app-misc/jq/jq-1.6-r3.ebuild b/app-misc/jq/jq-1.6-r3.ebuild
index 65410969fe53..e233ec8fa42e 100644
--- a/app-misc/jq/jq-1.6-r3.ebuild
+++ b/app-misc/jq/jq-1.6-r3.ebuild
@@ -60,6 +60,16 @@ src_configure() {
econf "${econfargs[@]}"
}
+src_test() {
+ if ! emake check; then
+ if [[ -r test-suite.log ]]; then
+ eerror "Tests failed, outputting testsuite log"
+ cat test-suite.log
+ fi
+ die "Tests failed"
+ fi
+}
+
src_install() {
local DOCS=( AUTHORS README.md )
default