summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:54:35 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:46 +0100
commitb55ba3559cb49c8d2aba6abad0caeee1aed0091f (patch)
tree8f6e5f4d9b992e2293550058889e8590a4061389 /app-misc/elasticsearch
parentapp-emulation/libvirt: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-b55ba3559cb49c8d2aba6abad0caeee1aed0091f.tar.gz
gentoo-b55ba3559cb49c8d2aba6abad0caeee1aed0091f.tar.bz2
gentoo-b55ba3559cb49c8d2aba6abad0caeee1aed0091f.zip
app-misc/elasticsearch: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/elasticsearch')
-rw-r--r--app-misc/elasticsearch/elasticsearch-6.8.15.ebuild2
-rw-r--r--app-misc/elasticsearch/elasticsearch-6.8.16.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/elasticsearch-6.8.15.ebuild b/app-misc/elasticsearch/elasticsearch-6.8.15.ebuild
index 6b347e7957c4..e090a2d2fede 100644
--- a/app-misc/elasticsearch/elasticsearch-6.8.15.ebuild
+++ b/app-misc/elasticsearch/elasticsearch-6.8.15.ebuild
@@ -72,6 +72,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
elog
elog "You may create multiple instances of ${PN} by"
elog "symlinking the init script:"
diff --git a/app-misc/elasticsearch/elasticsearch-6.8.16.ebuild b/app-misc/elasticsearch/elasticsearch-6.8.16.ebuild
index 6b347e7957c4..e090a2d2fede 100644
--- a/app-misc/elasticsearch/elasticsearch-6.8.16.ebuild
+++ b/app-misc/elasticsearch/elasticsearch-6.8.16.ebuild
@@ -72,6 +72,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
elog
elog "You may create multiple instances of ${PN} by"
elog "symlinking the init script:"