summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-04-16 10:58:54 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-04-16 10:58:54 +0900
commitcb7287bccaed0570a4ba35b36d908f01c4b1e36e (patch)
treeb7c681baa2ed3d8fbf3616fb5ee11345390961ad /app-i18n
parentsys-devel/gcc: add 12.2.1_p20230415 (diff)
downloadgentoo-cb7287bccaed0570a4ba35b36d908f01c4b1e36e.tar.gz
gentoo-cb7287bccaed0570a4ba35b36d908f01c4b1e36e.tar.bz2
gentoo-cb7287bccaed0570a4ba35b36d908f01c4b1e36e.zip
app-i18n/ibus-table: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.17.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 5a7689fb26fc..126d1031056d 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1 +1,2 @@
DIST ibus-table-1.16.14.tar.gz 1534056 BLAKE2B 512c1610e4e7096d25c5ff8678e0e91a4cae96ca7036dae0b33ef8f3461e0e6c89cddb35bcd0bf50c48d308d1b0831c02957863419ccbfba64182290a9567acb SHA512 a865c8913bee5e462ed8f3ba74a720b3eb37062ae762e3909827b660dc62d3055e6b90fd3c583487fb23edd2d9572d9eae201d7fbde889ec5cd8e5848b83291f
+DIST ibus-table-1.17.0.tar.gz 1545826 BLAKE2B 33890dffca38c76513f49a54419805aff1b13e79b069cdb655401a44eeb44201c4cc60a29e9b341bd25dc9431a6e15e0481dc7cbd3ad3f02ae07cfcc6f811c81 SHA512 2df316dfe34eca80d9d4f843a92f3452a939cd14bca3bfa6c021b0bc6b759676711fefba68b9bf10dfe48c2f82890452e9ae015986b520281998f4d08f2e763b
diff --git a/app-i18n/ibus-table/ibus-table-1.17.0.ebuild b/app-i18n/ibus-table/ibus-table-1.17.0.ebuild
new file mode 100644
index 000000000000..fa1d06003138
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.17.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}