summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-11-28 22:18:33 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-11-28 22:21:46 +0900
commit52a5b525540297c46540a4d10b3dfa2c78b1a709 (patch)
tree42fa358f51194960164a6be0924023290d9e7a14 /app-i18n
parentapp-admin/sysklogd: Bump to version 2.3.0 (diff)
downloadgentoo-52a5b525540297c46540a4d10b3dfa2c78b1a709.tar.gz
gentoo-52a5b525540297c46540a4d10b3dfa2c78b1a709.tar.bz2
gentoo-52a5b525540297c46540a4d10b3dfa2c78b1a709.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index e154561f047f..30c60dc6eb0e 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.14.12.tar.gz 10226257 BLAKE2B 5dae530a7ec425e8bd3c6009d0bdb9b8d321c8670769ddf80ba7f706d6b5140f21f184f877603de3cc6f425a4a1953c645eb177c9fa8183ecfd091ccfb32353a SHA512 09d1898c3ac8a1dc79768df7a44c33862a0b0fbb2122d184f1e8a839b8c3c71191fe5ef932f9e649ac715c8093a5c277d5783594f8defc06ecc13727b851ffa5
DIST ibus-typing-booster-2.14.13.tar.gz 10239396 BLAKE2B 1c4db896f28f3f1b58bd3071fb6f2d5c1b2b4e0fbad43568ae25d69f301d4ce408ca6c2fb829818f6981c2f212c499c1dfabc3511f09f7a9f5c3d4ae2d08a212 SHA512 4e1f1c39fea030f1f056966007127afeb5c6c098a66ecd6fe0b4ea60f302438e072d6d409ef2bee9ea5b0d1048b5a22d7e4fad9f7f509362e2af251855f6e535
+DIST ibus-typing-booster-2.15.7.tar.gz 10249949 BLAKE2B da2a24f66e3e8b57a91a71d521dc8c5d271bdba226d37870f0db0fb60ed9bb8f5fa1a752c6afdddb7044bd82b334d5a53810d7a64f5dbd439aaa19ab4a29117e SHA512 012e0ea8adf4f1f6ee02df05a306c0efd30cc6dd83b09496319390aa48a700a089e52d0ca46a6f3e077e39e4903b77e5c34715d33e7bf724d03c682c53bcb5e5
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.7.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.7.ebuild
new file mode 100644
index 000000000000..34ef03a80db1
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}