summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/x-unikey/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/x-unikey/files')
-rw-r--r--app-i18n/x-unikey/files/01x-unikey9
-rw-r--r--app-i18n/x-unikey/files/x-unikey-1.0.4-gcc43.patch12
-rw-r--r--app-i18n/x-unikey/files/x-unikey-1.0.4-gcc44.patch31
-rw-r--r--app-i18n/x-unikey/files/x-unikey-1.0.4-gentoo.patch20
4 files changed, 72 insertions, 0 deletions
diff --git a/app-i18n/x-unikey/files/01x-unikey b/app-i18n/x-unikey/files/01x-unikey
new file mode 100644
index 000000000000..595b6a183b55
--- /dev/null
+++ b/app-i18n/x-unikey/files/01x-unikey
@@ -0,0 +1,9 @@
+# x-unikey works only with *.UTF-8 locales
+#LANG=en_US.UTF-8
+
+# Uncomment this if you use XIM.
+#GTK_IM_MODULE="xim"
+#XMODIFIERS="@im=unikey"
+
+# If you use unikey-gtk only, then comment this
+#GTK_IM_MODULE="unikey"
diff --git a/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc43.patch b/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc43.patch
new file mode 100644
index 000000000000..c7e46ff686b8
--- /dev/null
+++ b/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc43.patch
@@ -0,0 +1,12 @@
+diff -Naur x-unikey-1.0.4.orig/src/ukengine/usrkeymap.cpp x-unikey-1.0.4/src/ukengine/usrkeymap.cpp
+--- x-unikey-1.0.4.orig/src/ukengine/usrkeymap.cpp 2008-12-18 00:39:38.000000000 +0900
++++ x-unikey-1.0.4/src/ukengine/usrkeymap.cpp 2008-12-18 00:38:56.000000000 +0900
+@@ -23,6 +23,8 @@
+
+ #include "stdafx.h"
+ #include <iostream>
++#include <cstring>
++
+ using namespace std;
+
+ #include <ctype.h>
diff --git a/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc44.patch b/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc44.patch
new file mode 100644
index 000000000000..5e59ca131b70
--- /dev/null
+++ b/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc44.patch
@@ -0,0 +1,31 @@
+diff -ur x-unikey-1.0.4.orig/src/ukengine/mactab.cpp x-unikey-1.0.4/src/ukengine/mactab.cpp
+--- x-unikey-1.0.4.orig/src/ukengine/mactab.cpp 2006-04-09 14:46:02.000000000 +0300
++++ x-unikey-1.0.4/src/ukengine/mactab.cpp 2009-08-10 14:50:50.000000000 +0300
+@@ -287,7 +287,7 @@
+ char key[MAX_MACRO_KEY_LEN];
+
+ // Parse the input item
+- char * pos = strchr(item, ':');
++ const char * pos = strchr(item, ':');
+ if (pos == NULL)
+ return -1;
+ int keyLen = (int)(pos - item);
+diff -ur x-unikey-1.0.4.orig/src/ukengine/usrkeymap.cpp x-unikey-1.0.4/src/ukengine/usrkeymap.cpp
+--- x-unikey-1.0.4.orig/src/ukengine/usrkeymap.cpp 2006-04-09 02:31:40.000000000 +0300
++++ x-unikey-1.0.4/src/ukengine/usrkeymap.cpp 2009-08-10 14:48:44.000000000 +0300
+@@ -21,6 +21,8 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
++#include <stdio.h>
++
+ #include "stdafx.h"
+ #include <iostream>
+ using namespace std;
+@@ -262,4 +264,4 @@
+ return i;
+ }
+ return -1;
+-}
+\ No newline at end of file
++}
diff --git a/app-i18n/x-unikey/files/x-unikey-1.0.4-gentoo.patch b/app-i18n/x-unikey/files/x-unikey-1.0.4-gentoo.patch
new file mode 100644
index 000000000000..e3bef43b98b2
--- /dev/null
+++ b/app-i18n/x-unikey/files/x-unikey-1.0.4-gentoo.patch
@@ -0,0 +1,20 @@
+--- x-unikey-1.0.4.orig/src/unikey-gtk/Makefile.am 2005-10-16 12:39:15.000000000 +0900
++++ x-unikey-1.0.4/src/unikey-gtk/Makefile.am 2008-12-18 00:48:37.000000000 +0900
+@@ -34,7 +34,7 @@
+
+ install-data-hook:
+ gtk-query-immodules-2.0 \
+- > @gtk_sysconfdir@/gtk.immodules
++ > $(DESTDIR)@gtk_sysconfdir@/gtk.immodules
+
+ ## $(moduledir)/im-vn.la \
+ ## @GTK_PREFIX@/lib/gtk-2.0/@GTK_VERSION@/immodules/*.la \
+@@ -42,7 +42,7 @@
+
+ uninstall-hook:
+ gtk-query-immodules-2.0 > \
+- @gtk_sysconfdir@/gtk.immodules
++ $(DESTDIR)@gtk_sysconfdir@/gtk.immodules
+ ## @GTK_PREFIX@/lib/gtk-2.0/@GTK_VERSION@/immodules/*.la \
+
+