summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-30 07:47:37 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-30 07:52:43 -0500
commit8ec1cfee4a677f64452a3879ebd664eb1b43efad (patch)
treea3f60ad8f9608c157f6f3e2942186f6312972e92 /app-emulation
parentnet-fs/s3fs: Stabilize 1.95 x86, #945463 (diff)
downloadgentoo-8ec1cfee4a677f64452a3879ebd664eb1b43efad.tar.gz
gentoo-8ec1cfee4a677f64452a3879ebd664eb1b43efad.tar.bz2
gentoo-8ec1cfee4a677f64452a3879ebd664eb1b43efad.zip
app-emulation/wine-mono: add 9.4.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-mono/Manifest2
-rw-r--r--app-emulation/wine-mono/wine-mono-9.4.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index df6ef4d72327..ef4a4d309c35 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -10,3 +10,5 @@ DIST wine-mono-9.2.0-x86.msi 84566016 BLAKE2B 08c106998536622cdda10065304416a338
DIST wine-mono-9.2.0-x86.tar.xz 43901320 BLAKE2B 125d81049bca105e8967338659dd21c174388dfc8be9802a5984b8fc11b4da22b82512590481d45ebd7554f89c5e9cad9c59b4406ba04436ada5b52ea2aea0cc SHA512 7d0039b7c77ed968c0e00eacd3bf716d3ec9dffc86f6cc2c2f9439320b889ae2e05cc4f9aade5e1a0122a86ee4b86cea4224e666aba0d0bb3f2fa6fb0d18f8ae
DIST wine-mono-9.3.0-x86.msi 84572160 BLAKE2B b6e13d5245b17c0f2857771c8bcfc7ca248d13f300df69970b5994d3287e3e4db0c49601b0cd29b7f6764f2abda5b54a3f0bf1ad1d2beb28033adba9276c7b5c SHA512 d5bb8ed9cc963292b37edb2ac3fb5945346b9632a080d5413ebde3470ff1702c9fdd0d4a25c0cd228e56abe11f6e1cf3d949a2c26099bf2fdef41aaf65f686ef
DIST wine-mono-9.3.0-x86.tar.xz 43906032 BLAKE2B 94dc27d305fb062f845064c07dcd00d2daaf9647ae5353e18267314b6534018bf22b1411981ef8e3cb9ef8fa0d91da662211376a309a243100d691386b1840e4 SHA512 094113aad504fa46d9f3b0ca6f7926c14fbda3edbbbc5dab307f19114fec0173a451a604b2083f399e61d5c6704971a0d602930cc9ba11502c863ec67318c480
+DIST wine-mono-9.4.0-x86.msi 84639232 BLAKE2B fc53dadf9c73c489f0333ab25aa2ce85df7f1dcf82fd475ea0265772441f1b29804bd378e555f71eafc851393c833c5aef97f10103257ccb6c6951c46fcb5bd9 SHA512 c8907d1f3b04bfc86a4d230148558964984f4ce33a732802ccbbc89b3593bce1c32b2fae105db0efa7e1e7ee97e955e51b682f06efe595408ba4031b55b8fe0f
+DIST wine-mono-9.4.0-x86.tar.xz 43941584 BLAKE2B a4d88b274e06a8f8f02e2f74e55fd0df5e4836f45295af711f2f3d3f2bf18432bc7c41c9c2392a0e6b584b67358740acd7f3572cafd32afd08060e8c9e060c0a SHA512 2ea3fa22f64019ff71b4c368e3b83608c2b0cf4ffb63fc349b29e41ddc17d015bf431d41788ce3139ddc19336690b9460c983d18eea514351f069671012895f2
diff --git a/app-emulation/wine-mono/wine-mono-9.4.0.ebuild b/app-emulation/wine-mono/wine-mono-9.4.0.ebuild
new file mode 100644
index 000000000000..43d16fc30de9
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-9.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="
+ https://gitlab.winehq.org/wine/wine/-/wikis/Wine-Mono/
+ https://gitlab.winehq.org/mono/wine-mono/
+"
+SRC_URI="
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+"
+S=${WORKDIR}
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+src_install() {
+ insinto /usr/share/wine/mono
+
+ if use shared; then
+ doins -r ${P}
+ else
+ doins "${DISTDIR}"/${P}-x86.msi
+ fi
+}