summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-21 22:11:18 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-21 23:30:58 -0400
commit41133645d8bd37dfb58374065b0a670e58948403 (patch)
treebc29a2c31477a974e755ad47b77214b5fec7c81e /app-emulation
parentRevert "app-emulation/vkd3d-proton: add workaround for gcc14 ICE w/ mingw" (diff)
downloadgentoo-41133645d8bd37dfb58374065b0a670e58948403.tar.gz
gentoo-41133645d8bd37dfb58374065b0a670e58948403.tar.bz2
gentoo-41133645d8bd37dfb58374065b0a670e58948403.zip
Revert "app-emulation/dxvk: add workaround for gcc14 ICE w/ mingw"
This reverts commit 0ee751a060fc66194a019a0fdd23bde99775cb01. Fixing in mingw64-toolchain instead, *could* keep the workaround longer for those that didn't update but likely doesn't affect many. Bug: https://bugs.gentoo.org/932319 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dxvk/dxvk-1.10.3-r1.ebuild3
-rw-r--r--app-emulation/dxvk/dxvk-2.3.1-r1.ebuild3
-rw-r--r--app-emulation/dxvk/dxvk-9999.ebuild3
3 files changed, 0 insertions, 9 deletions
diff --git a/app-emulation/dxvk/dxvk-1.10.3-r1.ebuild b/app-emulation/dxvk/dxvk-1.10.3-r1.ebuild
index 29d08dd1188a..701ccb453a83 100644
--- a/app-emulation/dxvk/dxvk-1.10.3-r1.ebuild
+++ b/app-emulation/dxvk/dxvk-1.10.3-r1.ebuild
@@ -79,9 +79,6 @@ src_configure() {
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
- # gcc14 -fno-omit-frame-pointer ICE workaround (bug #932319)
- append-flags -fomit-frame-pointer
-
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP
diff --git a/app-emulation/dxvk/dxvk-2.3.1-r1.ebuild b/app-emulation/dxvk/dxvk-2.3.1-r1.ebuild
index eef73bd94529..640326b8a12d 100644
--- a/app-emulation/dxvk/dxvk-2.3.1-r1.ebuild
+++ b/app-emulation/dxvk/dxvk-2.3.1-r1.ebuild
@@ -107,9 +107,6 @@ src_configure() {
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
- # gcc14 -fno-omit-frame-pointer ICE workaround (bug #932319)
- append-flags -fomit-frame-pointer
-
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP
diff --git a/app-emulation/dxvk/dxvk-9999.ebuild b/app-emulation/dxvk/dxvk-9999.ebuild
index 9309ae514030..9db73b208248 100644
--- a/app-emulation/dxvk/dxvk-9999.ebuild
+++ b/app-emulation/dxvk/dxvk-9999.ebuild
@@ -107,9 +107,6 @@ src_configure() {
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
- # gcc14 -fno-omit-frame-pointer ICE workaround (bug #932319)
- append-flags -fomit-frame-pointer
-
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP