summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/open-vm-tools/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/open-vm-tools/files')
-rw-r--r--app-emulation/open-vm-tools/files/9.10.0-vgauth.patch22
-rw-r--r--app-emulation/open-vm-tools/files/network22
-rw-r--r--app-emulation/open-vm-tools/files/open-vm-tools.confd2
-rw-r--r--app-emulation/open-vm-tools/files/open-vm-tools.desktop6
-rw-r--r--app-emulation/open-vm-tools/files/open-vm-tools.initd60
-rw-r--r--app-emulation/open-vm-tools/files/vmtoolsd.service11
6 files changed, 123 insertions, 0 deletions
diff --git a/app-emulation/open-vm-tools/files/9.10.0-vgauth.patch b/app-emulation/open-vm-tools/files/9.10.0-vgauth.patch
new file mode 100644
index 000000000000..aa8d1e3e353c
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/9.10.0-vgauth.patch
@@ -0,0 +1,22 @@
+--- a/vgauth/service/Makefile.am
++++ b/vgauth/service/Makefile.am
+@@ -78,7 +78,7 @@
+ $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) \
+ $(LDFLAGS) -o $@
+ else
+- VGAuthService_LINK = $(LINK)
++ VGAuthService_LINK = $(CXXLINK)
+ endif
+
+ # Message catalogs.
+--- a/vgauth/service/Makefile.in
++++ b/vgauth/service/Makefile.in
+@@ -322,7 +322,7 @@
+ ../lib/libvgauth.la @XERCES_LIBS@ @XMLSECURITY_LIBS@ \
+ @SSL_LIBS@ -lxerces-c -lxml-security-c -lssl -lcrypto \
+ $(am__append_1)
+-@HAVE_ICU_FALSE@VGAuthService_LINK = $(LINK)
++@HAVE_ICU_FALSE@VGAuthService_LINK = $(CXXLINK)
+ @HAVE_ICU_TRUE@VGAuthService_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
+ @HAVE_ICU_TRUE@ $(LIBTOOLFLAGS) --mode=link $(CXX) \
+ @HAVE_ICU_TRUE@ $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) \
diff --git a/app-emulation/open-vm-tools/files/network b/app-emulation/open-vm-tools/files/network
new file mode 100644
index 000000000000..3608455a9bc0
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/network
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+#
+# net.eth0, net.eth1, network, wicd, NetworkManager
+service="net.eth0"
+
+if ! rc-service -e ${service}
+then
+ service="network"
+fi
+
+case "$1" in
+ suspend-vm)
+ rc-service ${service} stop
+ ;;
+ resume-vm)
+ rc-service ${service} start
+ ;;
+ *)
+ ;;
+esac
+
diff --git a/app-emulation/open-vm-tools/files/open-vm-tools.confd b/app-emulation/open-vm-tools/files/open-vm-tools.confd
new file mode 100644
index 000000000000..4414fabdb46e
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/open-vm-tools.confd
@@ -0,0 +1,2 @@
+# Set this to no to disable drag and drop (and vmblock) loading.
+VM_DRAG_AND_DROP="yes"
diff --git a/app-emulation/open-vm-tools/files/open-vm-tools.desktop b/app-emulation/open-vm-tools/files/open-vm-tools.desktop
new file mode 100644
index 000000000000..97d4abf17f80
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/open-vm-tools.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Exec=vmware-user-suid-wrapper
+Name=VMware User Agent
+X-KDE-autostart-phase=1
+NoDisplay=true
diff --git a/app-emulation/open-vm-tools/files/open-vm-tools.initd b/app-emulation/open-vm-tools/files/open-vm-tools.initd
new file mode 100644
index 000000000000..6da69d4fb6ed
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/open-vm-tools.initd
@@ -0,0 +1,60 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+pidfile="/run/vmtoolsd.pid"
+command="/usr/bin/vmtoolsd"
+command_args="-b ${pidfile}"
+
+vmblockmntpt="/proc/fs/vmblock/mountPoint"
+vmblockfusemntpt="/run/vmblock-fuse"
+
+depend() {
+ before checkfs fsck net X
+}
+
+start_vmblock() {
+ checkpath -d -m 1777 /tmp/VMwareDnD
+ if command -v vmware-vmblock-fuse > /dev/null; then
+ modprobe fuse > /dev/null 2>&1
+ checkpath -d "${vmblockfusemntpt}"
+ ebegin "Mounting vmblock-fuse"
+ vmware-vmblock-fuse \
+ -o subtype=vmware-vmblock,default_permissions,allow_other \
+ "${vmblockfusemntpt}"
+ eend $?
+ else
+ modprobe vmblock > /dev/null 2>&1
+ checkpath -d "${vmblockmntpt}"
+ ebegin "Mounting vmblock"
+ mount -t vmblock vmblock "${vmblockmntpt}"
+ eend $?
+ fi
+}
+
+stop_vmblock() {
+ if [ -d "${vmblockfusemntpt}" ]; then
+ ebegin "Unmounting vmblock-fuse"
+ umount "${vmblockfusemntpt}"
+ eend $?
+ else
+ ebegin "Unmounting vmblock"
+ umount "${vmblockmntpt}"
+ eend $?
+ fi
+}
+
+start_pre() {
+ if [ x"${VM_DRAG_AND_DROP}" = xyes ]; then
+ start_vmblock
+ fi
+ return 0
+}
+
+stop_post() {
+ if [ x"${VM_DRAG_AND_DROP}" = xyes ]; then
+ stop_vmblock
+ fi
+ return 0
+}
diff --git a/app-emulation/open-vm-tools/files/vmtoolsd.service b/app-emulation/open-vm-tools/files/vmtoolsd.service
new file mode 100644
index 000000000000..426d4fbd993c
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/vmtoolsd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Service for virtual machines hosted on VMware
+Documentation=http://open-vm-tools.sourceforge.net/about.php
+ConditionVirtualization=vmware
+
+[Service]
+ExecStart=/usr/bin/vmtoolsd
+TimeoutStopSec=5
+
+[Install]
+WantedBy=multi-user.target