summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-06-04 09:42:54 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-04 09:43:53 -0700
commit8deba0e1e5786ea6a13a09df6b265295feb8e763 (patch)
tree43e4a32051789477bce87a2145b5095c30ec9f7b /app-emulation/buildah/buildah-1.7.1.ebuild
parentsci-libs/tensorflow-estimator: bump 1.14.0_rc0 (diff)
downloadgentoo-8deba0e1e5786ea6a13a09df6b265295feb8e763.tar.gz
gentoo-8deba0e1e5786ea6a13a09df6b265295feb8e763.tar.bz2
gentoo-8deba0e1e5786ea6a13a09df6b265295feb8e763.zip
app-emulation/buildah: remove old versions
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/buildah/buildah-1.7.1.ebuild')
-rw-r--r--app-emulation/buildah/buildah-1.7.1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-emulation/buildah/buildah-1.7.1.ebuild b/app-emulation/buildah/buildah-1.7.1.ebuild
deleted file mode 100644
index b70628774159..000000000000
--- a/app-emulation/buildah/buildah-1.7.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 golang-vcs-snapshot
-
-KEYWORDS="~amd64"
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="ostree selinux"
-EGO_PN="${HOMEPAGE#*//}"
-EGIT_COMMIT="v${PV}"
-GIT_COMMIT="93747b1"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-RDEPEND="app-crypt/gpgme:=
- app-emulation/skopeo
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-fs/lvm2:=
- sys-libs/libseccomp:=
- selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-RESTRICT="test"
-REQUIRED_USE="!selinux? ( !ostree )"
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
- default
- sed -e 's|^\(GIT_COMMIT ?= \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
-
- [[ -f ostree_tag.sh ]] || die
- use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
- ostree_tag.sh || die; }
-
- [[ -f selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- selinux_tag.sh || die; }
-}
-
-src_compile() {
- env -u GOCACHE -u XDG_CACHE_HOME GOPATH="${WORKDIR}/${P}" emake all
-}
-
-src_install() {
- dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
- doman docs/*.1
- dodoc -r docs/tutorials
- dobin ${PN} imgtype
- dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
- GOPATH="${WORKDIR}/${P}" emake test-unit
-}