summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-02-04 13:28:28 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-02-04 13:52:28 +0100
commitf8ded4cddb9e0e8ca110222790f4bee0c340ec02 (patch)
treebf96d79986ce6195485c612aab5fe925a6276a66 /app-emacs
parentapp-emacs/org-mode: bump to 9.7.21 (diff)
downloadgentoo-f8ded4cddb9e0e8ca110222790f4bee0c340ec02.tar.gz
gentoo-f8ded4cddb9e0e8ca110222790f4bee0c340ec02.tar.bz2
gentoo-f8ded4cddb9e0e8ca110222790f4bee0c340ec02.zip
app-emacs/transient: bump to 0.8.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-0.8.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index e5f23307536d..f037bbd91a25 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1,2 +1,3 @@
DIST transient-0.8.1.tar.gz 152761 BLAKE2B cc62becaff81b803cf0a7c843b1da4996cd06171ac151c1e54381f4e3d54b1b17105557577bd3fe1ae8fca2041c556dccbaf6a000ed1eef14434404b7f8022c5 SHA512 7d278452dbbd259654aa5f9576b94613224b7243f26445a364081a7e50eaf8fcc82d2699dceeffdd9a1364bcd4bc27af139b73ac90c251c45332247c0fe61c66
DIST transient-0.8.3.tar.gz 155293 BLAKE2B 2cf559409f1c6044f07513e6e3c5bd6ca1c180a863d90b28a9e4c4b933b5235226c5b8d2edcc7b9b19d0ae695dfb6135b071bb0e1fac03001f60595f94c006b3 SHA512 1be74143975f8f2b82b8c054f984b7aece6de803d6a4605266e1b2cb6dc00f71ea4d0bf70377bcdd863f01fd534a59d279502868d050d4eec86405916b511073
+DIST transient-0.8.4.tar.gz 159360 BLAKE2B eee6d277278f2e02ce7ef2dffe8cb6dd84d2239fc7e209b995c446ba356aaff42cbbc0b805d98bd7bd246fd30028a7b15e95a49c9eae7914916c2bc9eec2256f SHA512 79930beb74700025fe1381e5e718b1d0b4ca83bda25cf64e056f56dacca8d02a52bef0a557863f55f106f3faf851fc62c7323077e7de3e6bfa7c4131ebd883e0
diff --git a/app-emacs/transient/transient-0.8.4.ebuild b/app-emacs/transient/transient-0.8.4.ebuild
new file mode 100644
index 000000000000..de1c9d2bd003
--- /dev/null
+++ b/app-emacs/transient/transient-0.8.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.1.0
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+DOCS=( CHANGELOG README.org "docs/${PN}.org" )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ mv ./lisp/*.el . || die
+
+ elisp_src_prepare
+}