summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-28 22:59:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-28 23:08:50 +0100
commit5ba03831fbf94bd7aa045ecd2025f37f3c55cc9e (patch)
tree24f975a2ae552df358fec94e9b7ac3e7f21e9b84 /app-emacs
parentapp-emacs/corfu: bump to 1.7 (diff)
downloadgentoo-5ba03831fbf94bd7aa045ecd2025f37f3c55cc9e.tar.gz
gentoo-5ba03831fbf94bd7aa045ecd2025f37f3c55cc9e.tar.bz2
gentoo-5ba03831fbf94bd7aa045ecd2025f37f3c55cc9e.zip
app-emacs/corfu: sync live 9999 version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/corfu/corfu-9999.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/app-emacs/corfu/corfu-9999.ebuild b/app-emacs/corfu/corfu-9999.ebuild
index e1bbf4ca3ef1..e41321580543 100644
--- a/app-emacs/corfu/corfu-9999.ebuild
+++ b/app-emacs/corfu/corfu-9999.ebuild
@@ -1,36 +1,43 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-NEED_EMACS=27.1
+NEED_EMACS="28.1"
inherit elisp
DESCRIPTION="Completion Overlay Region FUnction"
HOMEPAGE="https://github.com/minad/corfu/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}"
else
SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
-RDEPEND=">=app-emacs/compat-29.1.3.4"
-BDEPEND="${RDEPEND}"
+RDEPEND="
+ >=app-emacs/compat-30.0.2.0
+"
+BDEPEND="
+ ${RDEPEND}
+"
DOCS=( README.org )
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
default
- mv extensions/*.el . || die
+
+ mv ./extensions/*.el . || die
}
src_compile() {