summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-24 00:29:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-24 01:12:12 +0200
commit205d79ae9ac0484382c5d3433fd758929eaa4370 (patch)
tree095fdb8fa7b28019766007b8766e45d0341e0ac5 /app-emacs
parentapp-emacs/cape: drop old 1.4 (diff)
downloadgentoo-205d79ae9ac0484382c5d3433fd758929eaa4370.tar.gz
gentoo-205d79ae9ac0484382c5d3433fd758929eaa4370.tar.bz2
gentoo-205d79ae9ac0484382c5d3433fd758929eaa4370.zip
app-emacs/cape: bump to 1.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/cape/Manifest1
-rw-r--r--app-emacs/cape/cape-1.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/cape/Manifest b/app-emacs/cape/Manifest
index 09b9750e5e46..c8527d3d788a 100644
--- a/app-emacs/cape/Manifest
+++ b/app-emacs/cape/Manifest
@@ -1 +1,2 @@
DIST cape-1.5.tar.gz 41327 BLAKE2B 5bf499786483161e485764b64dfe70f8aaf21e176e72f9a755fe0d681d107e690b28bc0c7d841b62154616e1dc38bf475577e7357719ce4e82a1184ac849e198 SHA512 d47e9c8b78a51e93e6dbd6c41440021eb117cb5c865a27cebeaf25a00891b7d315593e542f416c2b47c38f768b3fa663361f31798523534d60168dd68f2714b3
+DIST cape-1.6.tar.gz 41526 BLAKE2B 740c2bedaefa2cd05f01a010bcf5358aa97a14cd51242183113073be0a9504f00bd882971d9e88cc8b5d4c61c482536ea79c1b330b07dd8f0636751f1612d065 SHA512 33157f48acd7e14a14c6ecff125dfcdf68536a8e47965adaa4ebd2d5d1a4cde1928f65458c3a4d6ddc7c02bd4aa5054185e4a5342936972cb44e9df0aabe5606
diff --git a/app-emacs/cape/cape-1.6.ebuild b/app-emacs/cape/cape-1.6.ebuild
new file mode 100644
index 000000000000..99068b9ad304
--- /dev/null
+++ b/app-emacs/cape/cape-1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGELOG.org README.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+ elisp-make-autoload-file
+}