summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-25 18:42:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-25 18:48:24 +0200
commit011738bad3e28e474e66e3b58d6325be00ac59c4 (patch)
tree3cddb2e9561de7efd16d2069e3b9b408e9fffe9a /app-emacs
parentapp-emacs/jinx: bump to 1.10 (diff)
downloadgentoo-011738bad3e28e474e66e3b58d6325be00ac59c4.tar.gz
gentoo-011738bad3e28e474e66e3b58d6325be00ac59c4.tar.bz2
gentoo-011738bad3e28e474e66e3b58d6325be00ac59c4.zip
app-emacs/osm: bump to 1.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/osm/Manifest1
-rw-r--r--app-emacs/osm/osm-1.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/osm/Manifest b/app-emacs/osm/Manifest
index 8b94c3900863..ed2012c37313 100644
--- a/app-emacs/osm/Manifest
+++ b/app-emacs/osm/Manifest
@@ -1 +1,2 @@
DIST osm-1.3.tar.gz 35272 BLAKE2B 4cf6f5cc81f0cb710c2b33902373fe8102dc91c66242bf7b179ad8019ad91a3c91216d5f90ada9f00acde57f92722538c4803a6e891b11eb1b18fbdfec110c89 SHA512 221c8d236819aa7fd00350e20127a9b9eb87f8d9cbf319f1f319dae5d5c5580357e76409521e0921cb70e3cadee46e37580a454a206b67357e1ed6c727acc8ed
+DIST osm-1.4.tar.gz 35286 BLAKE2B ec45051f7a9045115891e9d38bd2f311b25d02f9da907aa3730eef174af84221c2ae1461e6f7d9b3a866f35f20599f36973a00c5df41551766d4d9d310dbd7df SHA512 afc5ac0b8aa592ddbc8e3fdc5e1472d58c21008952b9208d5d89a6ab666542f1239e67c1c95b25bc90bcc3ad3e5bb0dca06e725355ada1413cfbfce07cf13167
diff --git a/app-emacs/osm/osm-1.4.ebuild b/app-emacs/osm/osm-1.4.ebuild
new file mode 100644
index 000000000000..144330f58794
--- /dev/null
+++ b/app-emacs/osm/osm-1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="OpenStreetMap tile-based viewer for GNU Emacs"
+HOMEPAGE="https://github.com/minad/osm/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}:*[jpeg,json(+),libxml2,png,svg]
+ >=app-emacs/compat-29.1.4.0
+"
+RDEPEND="
+ ${BDEPEND}
+ net-misc/curl[ssl]
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}