summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/tdtd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/tdtd')
-rw-r--r--app-emacs/tdtd/Manifest1
-rw-r--r--app-emacs/tdtd/files/50tdtd-gentoo.el28
-rw-r--r--app-emacs/tdtd/metadata.xml5
-rw-r--r--app-emacs/tdtd/tdtd-0.7.1-r1.ebuild21
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/tdtd/Manifest b/app-emacs/tdtd/Manifest
new file mode 100644
index 000000000000..92fb5f6f9332
--- /dev/null
+++ b/app-emacs/tdtd/Manifest
@@ -0,0 +1 @@
+DIST tdtd071.zip 37673 SHA256 1e4a3b499187ef92b186d5cffa161f3377a9ee7bb44f3e9f5eafaa72cf862844 SHA512 3de529178718352bc437a3e91d3102990a88314d1dc5ad3d3120c6dfcbb1aef008edc00e46ee051fd5c968c698230393a301dd645484aa748b5b982df84e0556 WHIRLPOOL dca2378f48785c7de643791090f9724aa62ddbe16900cfdd50a53da95dcc42304b174ea3c4ebf10d069d373053f0587bf83d8c423b6ffe72bcc2cb3b5019aacd
diff --git a/app-emacs/tdtd/files/50tdtd-gentoo.el b/app-emacs/tdtd/files/50tdtd-gentoo.el
new file mode 100644
index 000000000000..3867c8faa137
--- /dev/null
+++ b/app-emacs/tdtd/files/50tdtd-gentoo.el
@@ -0,0 +1,28 @@
+
+;;; tdtd site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'dtd-mode "tdtd" "Major mode to edit DTD files." t)
+(autoload 'dtd-etags "tdtd"
+ "Execute etags on FILESPEC and match on DTD-specific regular expressions."
+ t)
+(autoload 'dtd-grep "tdtd" "Grep for PATTERN in files matching FILESPEC." t)
+
+;; Turn on font lock when in DTD mode
+(add-hook 'dtd-mode-hooks
+ 'turn-on-font-lock)
+
+(setq auto-mode-alist
+ (append
+ (list
+ '("\\.dcl$" . dtd-mode)
+ '("\\.dec$" . dtd-mode)
+ '("\\.dtd$" . dtd-mode)
+ '("\\.ele$" . dtd-mode)
+ '("\\.ent$" . dtd-mode)
+ '("\\.mod$" . dtd-mode))
+ auto-mode-alist))
+
+;; To use resize-minibuffer-mode, uncomment this and include in your .emacs:
+;;(resize-minibuffer-mode)
diff --git a/app-emacs/tdtd/metadata.xml b/app-emacs/tdtd/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/tdtd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild b/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..ddc8ece20042
--- /dev/null
+++ b/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit elisp
+
+DESCRIPTION="Emacs Major Mode for SGML and XML DTDs"
+HOMEPAGE="http://www.menteith.com/wiki/tdtd"
+SRC_URI="http://www.menteith.com/raw-attachment/wiki/tdtd/data/${PN}${PV//./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+SITEFILE=50${PN}-gentoo.el
+DOCS="TODO changelog.txt readme.txt tutorial.txt"