summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/psgml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/psgml')
-rw-r--r--app-emacs/psgml/Manifest1
-rw-r--r--app-emacs/psgml/files/50psgml-gentoo.el6
-rw-r--r--app-emacs/psgml/metadata.xml5
-rw-r--r--app-emacs/psgml/psgml-1.4.0.ebuild34
4 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/psgml/Manifest b/app-emacs/psgml/Manifest
new file mode 100644
index 000000000000..0863d1c80706
--- /dev/null
+++ b/app-emacs/psgml/Manifest
@@ -0,0 +1 @@
+DIST psgml-1.4.0.tar.gz 262246 SHA256 a1c4d5ae3c27b475bebbea539c0933b7a7356dd69c5e1498a4125e5ee2db46e5 SHA512 99bab6440a0f437009edff6371412c16f47d48c6b1eaa5b894523130e3a8d604ea79dc81f1895ceecd4283d0c7fd908d4e5bdeace63e54b9ac048a80fc0f6f44 WHIRLPOOL 12d300e30702beae1c67975388625f961cffb90aa13e3a62e32d3a0ce65bd15c3baf27cd5ddd99d768027f980f8f4b246de21322a3341577948cac957330bb5c
diff --git a/app-emacs/psgml/files/50psgml-gentoo.el b/app-emacs/psgml/files/50psgml-gentoo.el
new file mode 100644
index 000000000000..e69efe77d8f0
--- /dev/null
+++ b/app-emacs/psgml/files/50psgml-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'sgml-mode "psgml" "Major mode to edit SGML files." t)
+(autoload 'xml-mode "psgml" "Major mode to edit XML files." t)
+(setq sgml-catalog-files '("CATALOG" "/etc/sgml/catalog"))
+(setq sgml-display-char-list-filename
+ "@SITEETC@/iso88591.map")
diff --git a/app-emacs/psgml/metadata.xml b/app-emacs/psgml/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/psgml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/psgml/psgml-1.4.0.ebuild b/app-emacs/psgml/psgml-1.4.0.ebuild
new file mode 100644
index 000000000000..64e892ef8dab
--- /dev/null
+++ b/app-emacs/psgml/psgml-1.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A GNU Emacs Major Mode for editing SGML and XML coded documents"
+HOMEPAGE="http://sourceforge.net/projects/psgml/
+ http://www.emacswiki.org/emacs/PsgmlMode"
+SRC_URI="http://www.fsavigny.de/gpled-software/${P}.tar.gz"
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="app-text/openjade"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} --load psgml-maint.el -f psgml-compile-files || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "${SITEETC}/${PN}"
+ doins *.map
+ doinfo psgml.info psgml-api.info
+ dodoc ChangeLog INSTALL README.psgml psgml.ps
+}