summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-12 13:02:52 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-12 13:02:52 +0100
commitdfcf7a33e30834d032d0384ebd7cb8c06e3b20ba (patch)
tree6d2387d7b2b434a8ef757ca60a79fb757236d8cb /app-emacs/parseedn
parentapp-emacs/a: new package; add 1.0.0 (diff)
downloadgentoo-dfcf7a33e30834d032d0384ebd7cb8c06e3b20ba.tar.gz
gentoo-dfcf7a33e30834d032d0384ebd7cb8c06e3b20ba.tar.bz2
gentoo-dfcf7a33e30834d032d0384ebd7cb8c06e3b20ba.zip
app-emacs/parseedn: new package; add 1.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/parseedn')
-rw-r--r--app-emacs/parseedn/Manifest1
-rw-r--r--app-emacs/parseedn/files/50parseedn-gentoo.el1
-rw-r--r--app-emacs/parseedn/metadata.xml21
-rw-r--r--app-emacs/parseedn/parseedn-1.1.0.ebuild33
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/parseedn/Manifest b/app-emacs/parseedn/Manifest
new file mode 100644
index 000000000000..e66b805d42df
--- /dev/null
+++ b/app-emacs/parseedn/Manifest
@@ -0,0 +1 @@
+DIST parseedn-1.1.0.tar.gz 10455 BLAKE2B 2ffe006f254e34ad31e266ceb365cdc1532c4a4c3aaf2d0bd3e26791de560be5662d292436ad4dc4fb6d931e17a319443032ff4949e5e9e86ccf15d90ddac3b6 SHA512 cd7b2070e15f7ddf8ae9f01424400f04b638765c518ae00b3a07ca55de308d79da5aaafdcb1b58e04bc833ddd7c5842d102ff2a6f63ab8d4f6125dbb84bb375a
diff --git a/app-emacs/parseedn/files/50parseedn-gentoo.el b/app-emacs/parseedn/files/50parseedn-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/parseedn/files/50parseedn-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/parseedn/metadata.xml b/app-emacs/parseedn/metadata.xml
new file mode 100644
index 000000000000..0df1d0d9b4e9
--- /dev/null
+++ b/app-emacs/parseedn/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ parseedn is an Emacs Lisp library for parsing EDN data. It uses parseclj's
+ shift-reduce parser internally. EDN and Emacs Lisp have some important
+ differences that make translation from one to the other not transparent
+ (think representing an EDN map into Elisp, or being able to differentiate
+ between false and nil in Elisp). Because of this, parseedn takes certain
+ decisions when parsing and transforming EDN data into Elisp data types.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/clojure-emacs/parseedn/issues/</bugs-to>
+ <remote-id type="github">clojure-emacs/parseedn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/parseedn/parseedn-1.1.0.ebuild b/app-emacs/parseedn/parseedn-1.1.0.ebuild
new file mode 100644
index 000000000000..092ada16796a
--- /dev/null
+++ b/app-emacs/parseedn/parseedn-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="EDN parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseedn/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/parseclj"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/ert-runner )
+"
+
+ELISP_REMOVE="test/${PN}-test.el" # Remove bad tests.
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}