summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-10 15:23:51 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-10 17:35:31 +0200
commit059be50f3543bfbba06efad12eb048fddd3cf464 (patch)
tree2af7aaa4af9b944b36964e11524fc6851bb7aa7f /app-emacs/modus-themes
parentapp-emacs/compat: drop old 29.1.4.1 (diff)
downloadgentoo-059be50f3543bfbba06efad12eb048fddd3cf464.tar.gz
gentoo-059be50f3543bfbba06efad12eb048fddd3cf464.tar.bz2
gentoo-059be50f3543bfbba06efad12eb048fddd3cf464.zip
app-emacs/modus-themes: new package; add 4.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/modus-themes')
-rw-r--r--app-emacs/modus-themes/Manifest1
-rw-r--r--app-emacs/modus-themes/files/50modus-themes-gentoo.el2
-rw-r--r--app-emacs/modus-themes/metadata.xml18
-rw-r--r--app-emacs/modus-themes/modus-themes-4.2.0.ebuild30
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/modus-themes/Manifest b/app-emacs/modus-themes/Manifest
new file mode 100644
index 000000000000..618fe851a641
--- /dev/null
+++ b/app-emacs/modus-themes/Manifest
@@ -0,0 +1 @@
+DIST modus-themes-4.2.0.tar.gz 323621 BLAKE2B 7e5e19a294d802bcccfa6f1ca5b53b52ad584a634271d72ea63a5a061678b66149111e05dadc6d7dbb581a5c9dfd26a75f36abac3d87948324709474c204ec1f SHA512 a2484a9d7d42cfe0f74379f1f5bda02bc31a2fac16836644a3a6c6b568a6ee0e2d4804950732f2a132bef330bb7c0e34058256036f81afc27301262ffda79fae
diff --git a/app-emacs/modus-themes/files/50modus-themes-gentoo.el b/app-emacs/modus-themes/files/50modus-themes-gentoo.el
new file mode 100644
index 000000000000..179a80678b0e
--- /dev/null
+++ b/app-emacs/modus-themes/files/50modus-themes-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "modus-themes-autoloads" nil t)
diff --git a/app-emacs/modus-themes/metadata.xml b/app-emacs/modus-themes/metadata.xml
new file mode 100644
index 000000000000..900dd32712cb
--- /dev/null
+++ b/app-emacs/modus-themes/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Highly accessible themes, conforming with the highest standard for colour
+ contrast between background and foreground values (WCAG AAA). They also are
+ optimised for users with red-green colour deficiency.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/protesilaos/modus-themes/issues/</bugs-to>
+ <remote-id type="github">protesilaos/modus-themes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/modus-themes/modus-themes-4.2.0.ebuild b/app-emacs/modus-themes/modus-themes-4.2.0.ebuild
new file mode 100644
index 000000000000..b7a947039a4b
--- /dev/null
+++ b/app-emacs/modus-themes/modus-themes-4.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Convert symbol names between different naming conventions"
+HOMEPAGE="https://github.com/protesilaos/modus-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}