summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-07 22:53:21 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-07 23:21:57 +0100
commit13ff8a22f25dcc7de84b4c7064ac3c7c162c08a4 (patch)
treea1d29a39914b8d1d29229839ccbb87d129f43fd4 /app-emacs/flycheck
parentdev-dotnet/fable: bump to 4.11.0 (diff)
downloadgentoo-13ff8a22f25dcc7de84b4c7064ac3c7c162c08a4.tar.gz
gentoo-13ff8a22f25dcc7de84b4c7064ac3c7c162c08a4.tar.bz2
gentoo-13ff8a22f25dcc7de84b4c7064ac3c7c162c08a4.zip
app-emacs/flycheck: bump to 33.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/flycheck')
-rw-r--r--app-emacs/flycheck/Manifest1
-rw-r--r--app-emacs/flycheck/flycheck-33.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/flycheck/Manifest b/app-emacs/flycheck/Manifest
index 574ad195a233..28f5e45de879 100644
--- a/app-emacs/flycheck/Manifest
+++ b/app-emacs/flycheck/Manifest
@@ -1 +1,2 @@
DIST flycheck-32_p20230305.tar.gz 1044121 BLAKE2B 6a31ea589f0aca4ed6785fe3e45e5df4af9b084af2d4de9b707c2909db53fd2d3694559b35da69ba05240638a8105fddc5017e1ef037d9ad8a07c77b0efe905a SHA512 1b2d41df199328a297f0623585f4692529a656671b17fd5fbe4b6f9abd7320b2d81f7da6e3e0f17f4bc65474661310f99856a003670276ba6fb2a81780fc8377
+DIST flycheck-33.1.tar.gz 1043623 BLAKE2B b1659fbc8ebd1f6f4de3d02329a5afde40129584406ff371a536f6549dd0f530c655477bd2c14503c603c30f135e62296cef32e2fc454d429d223cd6d9d530c9 SHA512 66d1c384071d4ad21ffb6dcb7c040797a8bf802debe045acb3ae06980d0c5860cc88e8ebd80beeabca2ab80b3df8ab03c5924ff7e66ccaf2d54b5911bfade7b5
diff --git a/app-emacs/flycheck/flycheck-33.1.ebuild b/app-emacs/flycheck/flycheck-33.1.ebuild
new file mode 100644
index 000000000000..b4b987aac19a
--- /dev/null
+++ b/app-emacs/flycheck/flycheck-33.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Modern on-the-fly syntax checking extension for GNU Emacs"
+HOMEPAGE="https://www.flycheck.org/
+ https://github.com/flycheck/flycheck/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-emacs/dash-2.12.1
+ >=app-emacs/pkg-info-0.4
+"
+BDEPEND="
+ test? (
+ app-emacs/buttercup
+ app-emacs/shut-up
+ )
+"
+
+ELISP_REMOVE="
+ test/specs/test-documentation.el
+ test/specs/test-melpa-package.el
+"
+
+SITEFILE="50${PN}-gentoo-r1.el"
+DOCS=( CHANGES.rst README.md )
+
+elisp-enable-tests buttercup "${S}"
+
+src_compile() {
+ elisp-compile "${PN}.el"
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp-install "${PN}" ${PN}.el{,c} "${PN}-autoloads.el"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ einstalldocs
+}