summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/d-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/d-mode')
-rw-r--r--app-emacs/d-mode/Manifest1
-rw-r--r--app-emacs/d-mode/d-mode-2.0.6.ebuild20
-rw-r--r--app-emacs/d-mode/files/50d-mode-gentoo.el3
-rw-r--r--app-emacs/d-mode/files/d-mode-2.0.6-emacs-24.4.patch13
-rw-r--r--app-emacs/d-mode/metadata.xml8
5 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/d-mode/Manifest b/app-emacs/d-mode/Manifest
new file mode 100644
index 000000000000..f5594f0595e4
--- /dev/null
+++ b/app-emacs/d-mode/Manifest
@@ -0,0 +1 @@
+DIST d-mode-2.0.6.tar.gz 5465 SHA256 303ede6d2555ab935676ec4576d36c79bc880af86f37838a3b651b39f20a8f38 SHA512 8706459af61e49b3ca1ef6d4021abff752706b4dca9385c4fbe2b7c29ecb028dc3df558b1e9b3a358e5c38e3d2ab7121505583f95d3afdd9a06bc9449ed678f2 WHIRLPOOL 6f86955536c68fdc6da917c453d0e2ab9603de661abb6b2c504a298a8f76ad4111a0afa2ac0e5b585f8f7acb7a8a688fd3a3089726aa4150476acdd4364ae09c
diff --git a/app-emacs/d-mode/d-mode-2.0.6.ebuild b/app-emacs/d-mode/d-mode-2.0.6.ebuild
new file mode 100644
index 000000000000..910b6908839f
--- /dev/null
+++ b/app-emacs/d-mode/d-mode-2.0.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing D code"
+HOMEPAGE="https://github.com/Emacs-D-Mode-Maintainers/Emacs-D-Mode
+ http://www.emacswiki.org/emacs/DMode"
+SRC_URI="https://github.com/Emacs-D-Mode-Maintainers/Emacs-D-Mode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/Emacs-D-Mode-2.0.6"
+ELISP_PATCHES="${P}-emacs-24.4.patch"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/d-mode/files/50d-mode-gentoo.el b/app-emacs/d-mode/files/50d-mode-gentoo.el
new file mode 100644
index 000000000000..6fdf0dd8f397
--- /dev/null
+++ b/app-emacs/d-mode/files/50d-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'd-mode "d-mode" "Major mode for editing D code" t)
+(add-to-list 'auto-mode-alist '("\\.d[i]?\\'" . d-mode))
diff --git a/app-emacs/d-mode/files/d-mode-2.0.6-emacs-24.4.patch b/app-emacs/d-mode/files/d-mode-2.0.6-emacs-24.4.patch
new file mode 100644
index 000000000000..e8fc3500b48e
--- /dev/null
+++ b/app-emacs/d-mode/files/d-mode-2.0.6-emacs-24.4.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/536490
+https://bugs.gentoo.org/547026
+
+--- Emacs-D-Mode-2.0.6-orig/d-mode.el
++++ Emacs-D-Mode-2.0.6/d-mode.el
+@@ -66,6 +66,7 @@
+ ;; necessary to get them compiled.)
+ ;; Coment out 'when-compile part for debugging
+ (eval-when-compile
++ (require 'cl)
+ (require 'cc-langs)
+ (require 'cc-fonts)
+ )
diff --git a/app-emacs/d-mode/metadata.xml b/app-emacs/d-mode/metadata.xml
new file mode 100644
index 000000000000..dc4cb40bfcb1
--- /dev/null
+++ b/app-emacs/d-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="github">Emacs-D-Mode-Maintainers/Emacs-D-Mode</remote-id>
+</upstream>
+</pkgmetadata>