summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-08-12 09:09:25 +0200
committerUlrich Müller <ulm@gentoo.org>2023-08-12 09:18:45 +0200
commit70ab278203cea23a1baf354d5bf7c0af6ac135fb (patch)
treeaca2f1f99f40646b81ff9bd14e0eb8bbde72e0dc /app-emacs/apel
parentsec-keys/openpgp-keys-apache-tomcat: dropped obsolete ebuilds (diff)
downloadgentoo-70ab278203cea23a1baf354d5bf7c0af6ac135fb.tar.gz
gentoo-70ab278203cea23a1baf354d5bf7c0af6ac135fb.tar.bz2
gentoo-70ab278203cea23a1baf354d5bf7c0af6ac135fb.zip
app-emacs/apel: add 10.8_p20220721
Bug: https://bugs.gentoo.org/912089 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/apel')
-rw-r--r--app-emacs/apel/Manifest1
-rw-r--r--app-emacs/apel/apel-10.8_p20220721.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/apel/Manifest b/app-emacs/apel/Manifest
index 4e3c825febe6..7c3e87367f18 100644
--- a/app-emacs/apel/Manifest
+++ b/app-emacs/apel/Manifest
@@ -1 +1,2 @@
DIST apel-10.8_p20201106.tar.gz 69188 BLAKE2B e0107968349fe73325503a61fbc9ada83d657f2ca66a39ae2ea833543277f536d22371e371e17dc4307380e738491e20ec0b7b52a35207f49e37fa65c66f3ab1 SHA512 fb14570d6d4f2346d386ae0012cfb9149ddf9ade8b4dc75507e6cef848d12ef65f80bd7d1dc26815031aee00461d67d4a86fe29e30d5d542756e725425634c77
+DIST apel-10.8_p20220721.tar.gz 69181 BLAKE2B b7c36d4bec2f1a544cbf2e15c5ceb8968912e63dc7c4d68cf14d3f0a2646d7031c1595f8dd3f1e7622f8816a1c1b934b0987275ca4e05bcc3c770443f5db88ad SHA512 4d384cbc7989e1d1db4e4b735474d610e241ec4f551bcde73fa3a9771d1d1094f489bd5de328a9b5b66468bd64b52b3220a261735a646b4ea8818a29b3837be5
diff --git a/app-emacs/apel/apel-10.8_p20220721.ebuild b/app-emacs/apel/apel-10.8_p20220721.ebuild
new file mode 100644
index 000000000000..fdb9f15cbca4
--- /dev/null
+++ b/app-emacs/apel/apel-10.8_p20220721.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs"
+HOMEPAGE="https://github.com/wanderlust/apel"
+GITHUB_SHA1="82eb2325bd149dc57b43a9ce9402c6c6183e4052"
+SRC_URI="https://github.com/wanderlust/${PN}/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+SITEFILE="50apel-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ cat <<-EOF >>APEL-CFG || die
+ (setq APEL_PREFIX "apel")
+ (setq EMU_PREFIX "apel")
+ EOF
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" \
+ install
+ elisp-make-site-file "${SITEFILE}"
+ dodoc ChangeLog* README*
+}