summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2024-03-12 20:48:42 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-18 21:02:29 +0100
commit68989ea42eac5131c0d66f6790cf0ff2e0f3b9b8 (patch)
tree845844be6751d8e35e1cce4a8230a2382b596e4d /app-editors
parentx11-terms/cool-retro-term: drop 1.1.1-r2 (diff)
downloadgentoo-68989ea42eac5131c0d66f6790cf0ff2e0f3b9b8.tar.gz
gentoo-68989ea42eac5131c0d66f6790cf0ff2e0f3b9b8.tar.bz2
gentoo-68989ea42eac5131c0d66f6790cf0ff2e0f3b9b8.zip
app-editors/retext: fix desktop file issues
Move desktop file installation from python_install() to src_install(). Also, patch __main__.py to use the name "retext" for the desktop file (improves desktop environment compatibility). Closes: https://bugs.gentoo.org/925726 Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/retext/files/retext-8.0.1-fix-set-desktop-entry.patch15
-rw-r--r--app-editors/retext/retext-8.0.1-r1.ebuild85
2 files changed, 100 insertions, 0 deletions
diff --git a/app-editors/retext/files/retext-8.0.1-fix-set-desktop-entry.patch b/app-editors/retext/files/retext-8.0.1-fix-set-desktop-entry.patch
new file mode 100644
index 000000000000..0ff685b89152
--- /dev/null
+++ b/app-editors/retext/files/retext-8.0.1-fix-set-desktop-entry.patch
@@ -0,0 +1,15 @@
+# Set desktop file name to correspond to the one installed by
+# the ebuild ("retext.desktop").
+# Bug: https://bugs.gentoo.org/925726
+
+--- a/ReText/__main__.py
++++ b/ReText/__main__.py
+@@ -65,7 +65,7 @@ def main():
+ app.setApplicationDisplayName("ReText")
+ app.setApplicationVersion(app_version)
+ app.setOrganizationDomain('mitya57.me')
+- app.setDesktopFileName('me.mitya57.ReText.desktop')
++ app.setDesktopFileName('retext')
+ QNetworkProxyFactory.setUseSystemConfiguration(True)
+
+ RtTranslator = QTranslator()
diff --git a/app-editors/retext/retext-8.0.1-r1.ebuild b/app-editors/retext/retext-8.0.1-r1.ebuild
new file mode 100644
index 000000000000..8e3e6c409fc7
--- /dev/null
+++ b/app-editors/retext/retext-8.0.1-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="ReText"
+
+inherit desktop distutils-r1 optfeature qmake-utils virtualx xdg
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ >=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/PyQt6[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools
+ test? ( dev-python/PyQt6[testlib,${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-set-desktop-entry.patch
+)
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ # Needed for lrelease
+ export PATH="$(qt5_get_bindir):${PATH}"
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ virtx eunittest
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ newicon data/retext-kde5.png retext.png
+
+ # Fixme: The application actually provides a desktop file which theoretically
+ # could be used. So far though I could not make it install properly.
+ make_desktop_entry ${PN} "ReText" ${PN} "Office;WordProcessor"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "dictionary support" dev-python/pyenchant
+
+ einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
+ einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
+ einfo "For more details take a look at:"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}