summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-03-24 21:26:27 +0200
committerMart Raudsepp <leio@gentoo.org>2024-03-24 22:45:01 +0200
commit39c9f7c09b7b28cebce2cd3c7b0fcc9d9763041a (patch)
tree8d8828a984d5828baa7aa6e9ee7678518768026d /app-editors
parentdev-python/pyside2-tools: add 5.15.13 (diff)
downloadgentoo-39c9f7c09b7b28cebce2cd3c7b0fcc9d9763041a.tar.gz
gentoo-39c9f7c09b7b28cebce2cd3c7b0fcc9d9763041a.tar.bz2
gentoo-39c9f7c09b7b28cebce2cd3c7b0fcc9d9763041a.zip
app-editors/ghex: add 45.2, add missing dep
Closes: https://bugs.gentoo.org/913726 Closes: https://bugs.gentoo.org/916039 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-45.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index dada9f05f4f9..aba5186344af 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1,2 +1,3 @@
DIST ghex-44.2.tar.xz 897944 BLAKE2B 0db001b90390f7747792ac89a5daaf9d38165b72dce77c3a2fd41914a4386001b9f15aaf4352a3b41a204a9104a5234a6ac50a3a7269e10a151c000d57228480 SHA512 a06876e06488bb25b17fbdf17ea73e57f563fe49a414c173d680a6bf4db9b66b40fce90ad67cfb73c62f25d88f436a58b7e0fd588c7a664faf78c5058524cabf
DIST ghex-45.0.tar.xz 902480 BLAKE2B 9001be3c01a3f5974606180cede15e753ccda0ec6f4fa77cdaf3aea5030117d303b5cb4fb68dfb09de6aee87d76baf689ae250be457c41b8e4c9d3387b691e90 SHA512 1f6fa7da2e4cfcb89113780d2a0333ee322d608be3e7fccb958ea19a3c3fc368363597b99ff27bd54c929ab3e3afdb5d5f1dbe810d3ec04d9dd2c114bfc71c0f
+DIST ghex-45.2.tar.xz 902616 BLAKE2B 24e42b6d719280ab459d0ed7b96a502df7a5502e3d6cf385c0aa73b11808e40cac6112a3e0c3a228d5363578ccb875836efd8a13d6fc6c7e8ea4fe5a76bdb9c7 SHA512 2843b23a0673457ec72bd2aad20888fbc2ca890d3d859e6c2657af24cedc6185f6e11244574b603c0e32db2f54968e6584adf2c7e5abee84521c55148f536496
diff --git a/app-editors/ghex/ghex-45.2.ebuild b/app-editors/ghex/ghex-45.2.ebuild
new file mode 100644
index 000000000000..334559aea1bf
--- /dev/null
+++ b/app-editors/ghex/ghex-45.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4[introspection]
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}