summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-12-09 19:49:27 +0100
committerUlrich Müller <ulm@gentoo.org>2024-12-09 19:49:27 +0100
commit2f56c837a4fe858c678cf7d9534bcaf5441af70e (patch)
tree0d63b5c7711ac1c6aa678c33205badfa2a9f72ce /app-editors
parenteclass/tests: New test for eapi9-pipestatus.eclass (diff)
downloadgentoo-2f56c837a4fe858c678cf7d9534bcaf5441af70e.tar.gz
gentoo-2f56c837a4fe858c678cf7d9534bcaf5441af70e.tar.bz2
gentoo-2f56c837a4fe858c678cf7d9534bcaf5441af70e.zip
app-editors/emacs: Replace assert with pipestatus
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-26.3-r21.ebuild6
-rw-r--r--app-editors/emacs/emacs-27.2-r19.ebuild6
-rw-r--r--app-editors/emacs/emacs-28.2-r15.ebuild6
-rw-r--r--app-editors/emacs/emacs-29.4-r1.ebuild6
-rw-r--r--app-editors/emacs/emacs-30.0.91.ebuild6
-rw-r--r--app-editors/emacs/emacs-30.0.92.ebuild6
-rw-r--r--app-editors/emacs/emacs-30.0.9999-r1.ebuild6
-rw-r--r--app-editors/emacs/emacs-31.0.9999.ebuild6
8 files changed, 24 insertions, 24 deletions
diff --git a/app-editors/emacs/emacs-26.3-r21.ebuild b/app-editors/emacs/emacs-26.3-r21.ebuild
index e9938a4c6219..7a019f707cab 100644
--- a/app-editors/emacs/emacs-26.3-r21.ebuild
+++ b/app-editors/emacs/emacs-26.3-r21.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic readme.gentoo-r1
+inherit autotools eapi9-pipestatus elisp-common flag-o-matic readme.gentoo-r1
DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
HOMEPAGE="https://www.gnu.org/software/emacs/"
@@ -284,14 +284,14 @@ src_install() {
-e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
-e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
etc/emacs.service | newins - ${EMACS_SUFFIX}.service
- assert
+ pipestatus || die
fi
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
-name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
- assert "gzip .el failed"
+ pipestatus || die "gzip .el pipeline failed"
fi
local cdir
diff --git a/app-editors/emacs/emacs-27.2-r19.ebuild b/app-editors/emacs/emacs-27.2-r19.ebuild
index 9057ada871ab..38117bed7e91 100644
--- a/app-editors/emacs/emacs-27.2-r19.ebuild
+++ b/app-editors/emacs/emacs-27.2-r19.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
+inherit autotools eapi9-pipestatus elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV##*.} = 9999 ]]; then
inherit git-r3
@@ -352,14 +352,14 @@ src_install() {
-e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
-e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
etc/emacs.service | newins - ${EMACS_SUFFIX}.service
- assert
+ pipestatus || die
fi
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
-name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
- assert "gzip .el failed"
+ pipestatus || die "gzip .el pipeline failed"
fi
local cdir
diff --git a/app-editors/emacs/emacs-28.2-r15.ebuild b/app-editors/emacs/emacs-28.2-r15.ebuild
index 7b5d0c431e99..a9fefb16ffa8 100644
--- a/app-editors/emacs/emacs-28.2-r15.ebuild
+++ b/app-editors/emacs/emacs-28.2-r15.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
+inherit autotools eapi9-pipestatus elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV##*.} = 9999 ]]; then
inherit git-r3
@@ -448,14 +448,14 @@ src_install() {
-e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
-e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
etc/emacs.service | newins - ${EMACS_SUFFIX}.service
- assert
+ pipestatus || die
fi
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
-name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
- assert "gzip .el failed"
+ pipestatus || die "gzip .el pipeline failed"
fi
local cdir
diff --git a/app-editors/emacs/emacs-29.4-r1.ebuild b/app-editors/emacs/emacs-29.4-r1.ebuild
index 13447ae2ea93..986bb85573bf 100644
--- a/app-editors/emacs/emacs-29.4-r1.ebuild
+++ b/app-editors/emacs/emacs-29.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
+inherit autotools eapi9-pipestatus elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV##*.} = 9999 ]]; then
inherit git-r3
@@ -530,14 +530,14 @@ src_install() {
-e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
-e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
etc/emacs.service | newins - ${EMACS_SUFFIX}.service
- assert
+ pipestatus || die
fi
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
-name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
- assert "gzip .el failed"
+ pipestatus || die "gzip .el pipeline failed"
fi
local cdir
diff --git a/app-editors/emacs/emacs-30.0.91.ebuild b/app-editors/emacs/emacs-30.0.91.ebuild
index 0cd4d0582c91..115d3351a136 100644
--- a/app-editors/emacs/emacs-30.0.91.ebuild
+++ b/app-editors/emacs/emacs-30.0.91.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
+inherit autotools eapi9-pipestatus elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV##*.} = 9999 ]]; then
inherit git-r3
@@ -517,14 +517,14 @@ src_install() {
-e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
-e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
etc/emacs.service | newins - ${EMACS_SUFFIX}.service
- assert
+ pipestatus || die
fi
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
-name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
- assert "gzip .el failed"
+ pipestatus || die "gzip .el pipeline failed"
fi
local cdir
diff --git a/app-editors/emacs/emacs-30.0.92.ebuild b/app-editors/emacs/emacs-30.0.92.ebuild
index 0cd4d0582c91..115d3351a136 100644
--- a/app-editors/emacs/emacs-30.0.92.ebuild
+++ b/app-editors/emacs/emacs-30.0.92.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
+inherit autotools eapi9-pipestatus elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV##*.} = 9999 ]]; then
inherit git-r3
@@ -517,14 +517,14 @@ src_install() {
-e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
-e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
etc/emacs.service | newins - ${EMACS_SUFFIX}.service
- assert
+ pipestatus || die
fi
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
-name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
- assert "gzip .el failed"
+ pipestatus || die "gzip .el pipeline failed"
fi
local cdir
diff --git a/app-editors/emacs/emacs-30.0.9999-r1.ebuild b/app-editors/emacs/emacs-30.0.9999-r1.ebuild
index 0cd4d0582c91..115d3351a136 100644
--- a/app-editors/emacs/emacs-30.0.9999-r1.ebuild
+++ b/app-editors/emacs/emacs-30.0.9999-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
+inherit autotools eapi9-pipestatus elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV##*.} = 9999 ]]; then
inherit git-r3
@@ -517,14 +517,14 @@ src_install() {
-e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
-e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
etc/emacs.service | newins - ${EMACS_SUFFIX}.service
- assert
+ pipestatus || die
fi
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
-name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
- assert "gzip .el failed"
+ pipestatus || die "gzip .el pipeline failed"
fi
local cdir
diff --git a/app-editors/emacs/emacs-31.0.9999.ebuild b/app-editors/emacs/emacs-31.0.9999.ebuild
index d1f3581d8ccd..207974933838 100644
--- a/app-editors/emacs/emacs-31.0.9999.ebuild
+++ b/app-editors/emacs/emacs-31.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
+inherit autotools eapi9-pipestatus elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV##*.} = 9999 ]]; then
inherit git-r3
@@ -517,14 +517,14 @@ src_install() {
-e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
-e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
etc/emacs.service | newins - ${EMACS_SUFFIX}.service
- assert
+ pipestatus || die
fi
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
-name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
- assert "gzip .el failed"
+ pipestatus || die "gzip .el pipeline failed"
fi
local cdir