summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-14 11:51:20 +0100
committerSam James <sam@gentoo.org>2024-06-14 11:51:20 +0100
commit4355c6c6714ef094ad63c62617267cc54eaebabd (patch)
tree96c72665c541587c61727ff6839e28fd017f8003 /app-doc
parentnet-print/splix: add 2.0.1 (diff)
downloadgentoo-4355c6c6714ef094ad63c62617267cc54eaebabd.tar.gz
gentoo-4355c6c6714ef094ad63c62617267cc54eaebabd.tar.bz2
gentoo-4355c6c6714ef094ad63c62617267cc54eaebabd.zip
app-doc/eclass-manpages: add 20240614
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/eclass-manpages/Manifest1
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-20240614.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-doc/eclass-manpages/Manifest b/app-doc/eclass-manpages/Manifest
index e83f7296cd36..2394e20fe3ba 100644
--- a/app-doc/eclass-manpages/Manifest
+++ b/app-doc/eclass-manpages/Manifest
@@ -2,3 +2,4 @@ DIST eclass-manpages-20240207.tar.xz 446596 BLAKE2B 5d9698a72586a2a33149f02fb709
DIST eclass-manpages-20240229.tar.xz 448264 BLAKE2B ce7692c14f9f051b991ae292fd8329de2457cb63c803fec8a16677f92fd2214c695bf077309c16aa0a97318bb99ff83e8ebe2028865b6ac3740e480b00646c8c SHA512 eaa545b2dcbfafef140f8682afde24ae0a225ca666ca353191a432ece64bb85f759955cfcb1b26c665b1e760835963c3c566f1bd899f2e56b139a700d1f3fafb
DIST eclass-manpages-20240423.tar.xz 451300 BLAKE2B 12c5bbfbf97a942bee6533424b1ffb3327f09b390c4ac8d90e993149b5244339605122cdf5dc169f0f97449c755f0047798489d374421678c560c3619086ebfc SHA512 4625e745af1f28d0ebfe3b5ea0b874186b2de863eb129722f952b8b4336ac108e84556a56b9b212f288c63c3910896d940dc12d2d2287eef9bc12d39e6922728
DIST eclass-manpages-20240512.tar.xz 452732 BLAKE2B e39fe919e90d24247ff1a5153359d4bc9dae8d4d8a47c0d2231a6364e64b046f813d507aa95cf5b7fca9de862678d7d584381fa94d6a4019cc07d5474d73f8e3 SHA512 a798cd71eb33a63bc8ceeaf1103f130425e4b82d379d413ce09605f4c9648447d01f97875cfe2efdd09a2dace7a73bf3a74f223168da8035ef13f1a52dd58677
+DIST eclass-manpages-20240614.tar.xz 450756 BLAKE2B 50435ab646a238f47cc96573af3d8ed53e14b700c9284253a2a9efbda40fc058f475a9900e56c3d6575ceafa4385eec89d9d1df87dd5ec94425c69daf258ab0e SHA512 80c0ba3eac7affc670f10d2eca58293bb79de94cc3b9d2349dd9b2227efd02b08d7e8a095161b484f87b3e23042afea73fadbd0cff867006bfbbb748a5051c55
diff --git a/app-doc/eclass-manpages/eclass-manpages-20240614.ebuild b/app-doc/eclass-manpages/eclass-manpages-20240614.ebuild
new file mode 100644
index 000000000000..83b196078ae7
--- /dev/null
+++ b/app-doc/eclass-manpages/eclass-manpages-20240614.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Instructions to make a dist tarball:
+# git clone https://github.com/projg2/eclass-to-manpage.git
+# cd eclass-to-manpage
+# make dist ECLASSDIR=~/g/eclass/
+
+DESCRIPTION="Collection of Gentoo eclass manpages"
+HOMEPAGE="https://github.com/projg2/eclass-to-manpage"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Keep the keywords stable. No need to change to ~arch.
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="sys-apps/gawk"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}