summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-11-29 20:09:33 +0100
committerUlrich Müller <ulm@gentoo.org>2015-11-29 20:14:50 +0100
commit6b8ab6e5dadf836b96f7bf91434b40084bff2f69 (patch)
tree95d6993adfc6dab544f89287d51cf03e1dc1d990 /app-doc/elisp-manual/elisp-manual-24.5.ebuild
parentmedia-libs/lensfun: arm stable, bug #566390 (diff)
downloadgentoo-6b8ab6e5dadf836b96f7bf91434b40084bff2f69.tar.gz
gentoo-6b8ab6e5dadf836b96f7bf91434b40084bff2f69.tar.bz2
gentoo-6b8ab6e5dadf836b96f7bf91434b40084bff2f69.zip
app-doc/elisp-manual: Version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-24.5.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-24.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-24.5.ebuild b/app-doc/elisp-manual/elisp-manual-24.5.ebuild
new file mode 100644
index 000000000000..be509e94b404
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-24.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
+# taken from doc/lispref/ of emacs-${PV}
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="FDL-1.3+"
+SLOT="24"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+DEPEND="app-arch/xz-utils
+ sys-apps/texinfo"
+
+S="${WORKDIR}/lispref"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-direntry.patch"
+ echo "@set EMACSVER ${PV}" >emacsver.texi || die
+}
+
+src_compile() {
+ makeinfo elisp.texi || die
+}
+
+src_install() {
+ doinfo elisp${SLOT}.info*
+ dodoc ChangeLog README
+}