summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 11:38:09 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 12:42:31 +0200
commit1fd73ead2748247631b9d6a73c766fe3280cbb26 (patch)
tree9628906dff7fa3a3c281872daa6b3dc57ce46512 /app-dicts/gnome-dictionary
parentsys-apps/ethtool: Bump to version 4.6 (diff)
downloadgentoo-1fd73ead2748247631b9d6a73c766fe3280cbb26.tar.gz
gentoo-1fd73ead2748247631b9d6a73c766fe3280cbb26.tar.bz2
gentoo-1fd73ead2748247631b9d6a73c766fe3280cbb26.zip
app-dicts/gnome-dictionary: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-dicts/gnome-dictionary')
-rw-r--r--app-dicts/gnome-dictionary/Manifest1
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.20.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
index aa5896ed593b..ab90415c9d03 100644
--- a/app-dicts/gnome-dictionary/Manifest
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -1 +1,2 @@
DIST gnome-dictionary-3.18.1.tar.xz 864460 SHA256 92cf2d519335b125018468c22405499fdb320e4446201c7b0f55f1a441bf05cc SHA512 efe4d1f8810bf218bae4d393be1d26938ed3a814ed22fb96c0bded5f874c32229b215351b08462eef1c92b756640a3d4e1c0f5ea1ee49f67e519bcf0d53aba74 WHIRLPOOL c20c73504e8ce0745170ec21296191d14770f252c80b208e4ac08659f80d2ece79cd2d408b4e3bdee992475a67be2ec77f4c16e501e8bbbebe8c0a95c3911e7b
+DIST gnome-dictionary-3.20.0.tar.xz 871916 SHA256 efb36377d46eff9291d3b8fec37baab2355f9dc8bc7edb791b6a625574716121 SHA512 9be2564b5bf543e80afdb946c16b16e2daf6c31875e352b7c2d7e34436791fc9470eadb42eba3a4c1893e2f2568e6bb88d19ea4a0b8dbb2eca2dd4c95aeaf229 WHIRLPOOL 4c22c0b2f7f668f5efc3857ba4bf33808d52a524b4d8ccbe1ac91839daff97d7271cf5f8196c0fbaa47266bb83f9f0705c83d1fe5949f633bfa50269554e057f
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.20.0.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.20.0.ebuild
new file mode 100644
index 000000000000..b913a631acc6
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.20.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0/10" # subslot = suffix of libgdict-1.0.so
+IUSE="debug +introspection ipv6"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39:2[dbus]
+ x11-libs/cairo:=
+ >=x11-libs/gtk+-3.16:3
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ dev-util/itstool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ $(use_enable ipv6)
+}