summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-15 07:12:05 +0100
committerSam James <sam@gentoo.org>2023-04-15 07:12:05 +0100
commit5eb71eb142a2a51e52580bb81fa42834bf3a7e96 (patch)
tree9aac34c62d7bdc4411cf0b281465f70d7d1f5df5 /app-crypt
parentapp-backup/amanda: fix configure w/ clang 16 (diff)
downloadgentoo-5eb71eb142a2a51e52580bb81fa42834bf3a7e96.tar.gz
gentoo-5eb71eb142a2a51e52580bb81fa42834bf3a7e96.tar.bz2
gentoo-5eb71eb142a2a51e52580bb81fa42834bf3a7e96.zip
app-crypt/seahorse: fix build w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/files/seahorse-43.0-clang16.patch35
-rw-r--r--app-crypt/seahorse/seahorse-43.0-r2.ebuild (renamed from app-crypt/seahorse/seahorse-43.0-r1.ebuild)1
2 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/seahorse/files/seahorse-43.0-clang16.patch b/app-crypt/seahorse/files/seahorse-43.0-clang16.patch
new file mode 100644
index 000000000000..c31fc42709e1
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-43.0-clang16.patch
@@ -0,0 +1,35 @@
+https://gitlab.gnome.org/GNOME/seahorse/-/merge_requests/214
+
+From 3887ba07ccab4aa970c24a22a183b97e255e6ece Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 14 Apr 2023 14:37:23 +0200
+Subject: [PATCH] Avoid C99 incompatibility around
+ seahorse_pkcs11_backend_initialize
+
+Move the prototype for seahorse_pkcs11_backend_initialize into the
+header file, so C code generated from Vala sources will use it.
+This avoids an implicit function declaration during the C-build
+of src/application.vala, and resulting build failures with future
+compilers.
+--- a/pkcs11/seahorse-pkcs11-backend.c
++++ b/pkcs11/seahorse-pkcs11-backend.c
+@@ -43,8 +43,6 @@ enum {
+ PROP_LOADED,
+ };
+
+-void seahorse_pkcs11_backend_initialize (void);
+-
+ static SeahorsePkcs11Backend *pkcs11_backend = NULL;
+
+ struct _SeahorsePkcs11Backend {
+--- a/pkcs11/seahorse-pkcs11-backend.h
++++ b/pkcs11/seahorse-pkcs11-backend.h
+@@ -43,4 +43,6 @@ SeahorsePkcs11Backend * seahorse_pkcs11_backend_get (void);
+ GcrCollection * seahorse_pkcs11_backend_get_writable_tokens (SeahorsePkcs11Backend *self,
+ gulong with_mechanism);
+
++void seahorse_pkcs11_backend_initialize (void);
++
+ #endif /* SEAHORSE_PKCS11_BACKEND_H_ */
+--
+GitLab
diff --git a/app-crypt/seahorse/seahorse-43.0-r1.ebuild b/app-crypt/seahorse/seahorse-43.0-r2.ebuild
index 876b56992f86..54b472f9d3d2 100644
--- a/app-crypt/seahorse/seahorse-43.0-r1.ebuild
+++ b/app-crypt/seahorse/seahorse-43.0-r2.ebuild
@@ -50,6 +50,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-gnupg-2.4.patch
"${FILESDIR}"/${P}-musl-stdout.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {