summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-11-23 18:45:35 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-11-23 18:46:23 -0600
commit4664fe2334cf589014202492c9237e78638a40a5 (patch)
tree35eea8f8f773ec8def1b19145dadc2ff27d26c91 /app-crypt
parentsci-mathematics/coq: fix eclass usage (diff)
downloadgentoo-4664fe2334cf589014202492c9237e78638a40a5.tar.gz
gentoo-4664fe2334cf589014202492c9237e78638a40a5.tar.bz2
gentoo-4664fe2334cf589014202492c9237e78638a40a5.zip
app-crypt/cfssl: 1.4.1 bump
Closes: https://bugs.gentoo.org/700868 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/cfssl/Manifest1
-rw-r--r--app-crypt/cfssl/cfssl-1.4.1.ebuild30
-rw-r--r--app-crypt/cfssl/files/cfssl-1.4.1-build-fix.patch16
3 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/cfssl/Manifest b/app-crypt/cfssl/Manifest
index b7af606c042e..e81cd19c9060 100644
--- a/app-crypt/cfssl/Manifest
+++ b/app-crypt/cfssl/Manifest
@@ -1,3 +1,4 @@
DIST cfssl-1.3.2.tar.gz 6867118 BLAKE2B 775b3419ecf878d9add13faf03a3e1d4cca7b30d965f1ca55c8faa5abf679188a1ea1f80c1416f19c85bc551395628a31da8669ca647e1c1e7a1a313d68f4c7b SHA512 aba27a282c8ca8e95769996aea7e5300b0c3f8fea7ae26484d19a7e1a0330f0b3a0649407062f1a10e8c93136693954e3b24c92456f69db3abee509f982ba554
DIST cfssl-1.3.3.tar.gz 5005924 BLAKE2B 81e7ec1f27a6597d69f16254a5ded672b9b3ac0bc8dee0f5bb00939e86147b1ed0389d38ea406fe671f3de052ac2e88fe320ffbf6065a83c2d9627ac3c497740 SHA512 39b42f3f8c22e254fa8ed4079308ecad1b0f77cdb56e57099e434389866e58863687307d6cf0f5ec8e4664ad4743ee8728f47a6a1375f3f74f8206a709f0ffc3
DIST cfssl-1.3.4.tar.gz 7092440 BLAKE2B 85a7a73ae5b18ae0e4ac02b1a4d5f633d73f2c0f81cb49ef85c39b6a241ac538220a8cebb448af795140a6308f46f6e53003f25a31edad452cb6db39ff95a9b2 SHA512 796f24f9a7cd9966b3586b5b08deb410570cc31ec747b0c834215c105df1b4fea4907bfa223d196ad71fb296724dc690b6ffd298c8ef81db1333ed3e69f1ecd4
+DIST cfssl-1.4.1.tar.gz 5736648 BLAKE2B 581627eb269fcbbbe9ff3afe558c6ddc7afa10f563444899244045baa0ae195d8822b389e7c59bec6c9135b1159b18d2a5e497c83cd26eaa47a3a87de23ce694 SHA512 0aa557708a300e2eaf48a99d55794069530b6842584cdd867a864272b205c89d5abc2acf3a19d34b3b5519a6429b5f55685129638e65d574ad6afe5b7e1e1e8f
diff --git a/app-crypt/cfssl/cfssl-1.4.1.ebuild b/app-crypt/cfssl/cfssl-1.4.1.ebuild
new file mode 100644
index 000000000000..68c4204008c1
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+SRC_URI="https://github.com/cloudflare/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hardened"
+
+RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
+
+PATCHES=(
+ "${FILESDIR}/${P}-build-fix.patch"
+)
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
+}
+
+src_install() {
+ dobin bin/*
+ dodoc CHANGELOG README.md
+}
diff --git a/app-crypt/cfssl/files/cfssl-1.4.1-build-fix.patch b/app-crypt/cfssl/files/cfssl-1.4.1-build-fix.patch
new file mode 100644
index 000000000000..0435a3c88509
--- /dev/null
+++ b/app-crypt/cfssl/files/cfssl-1.4.1-build-fix.patch
@@ -0,0 +1,16 @@
+This patch cannot be upstreamed in this form. However, the following
+issue has been opened to discuss integrating a better solution upstream.
+
+https://github.com/cloudflare/cfssl/issues/1062
+
+diff --git a/Makefile b/Makefile
+index 10a52fc..7fc019b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,4 @@
+-VERSION := $(shell git describe --tags --abbrev=0 | tr -d '[:alpha:]')
+-LDFLAGS := "-s -w -X github.com/cloudflare/cfssl/cli/version.version=$(VERSION)"
++LDFLAGS := "-X github.com/cloudflare/cfssl/cli/version.version=$(VERSION)"
+
+ export GOFLAGS := -mod=vendor
+ export GOPROXY := off