summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/gpgstats
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/gpgstats')
-rw-r--r--app-crypt/gpgstats/Manifest1
-rw-r--r--app-crypt/gpgstats/files/gpgstats-0.5-flags.patch25
-rw-r--r--app-crypt/gpgstats/gpgstats-0.5-r1.ebuild29
-rw-r--r--app-crypt/gpgstats/metadata.xml8
4 files changed, 63 insertions, 0 deletions
diff --git a/app-crypt/gpgstats/Manifest b/app-crypt/gpgstats/Manifest
new file mode 100644
index 000000000000..efbda2052db1
--- /dev/null
+++ b/app-crypt/gpgstats/Manifest
@@ -0,0 +1 @@
+DIST gpgstats-0.5.tgz 6691 SHA256 beb3c5037b27e1edf10c47ceefaebb39c7f75b42b376a03ba3d43d2e219676d8 SHA512 273f08af37089eb43cee65fa06ff8023e1951fa4649bf208e01d6bc453e4131c11128b511c6cbd8396a7bd93722904e8930168656994e3d4d055024c3d5fb649 WHIRLPOOL be8d7a3d905ecf18a52e528d9c450c95900d1175b62ea2c6c708829f6fe230b1f67e75160049a3419c6c8933e14dfd3b33372d8913b9fa71a3f9150e7db4a63b
diff --git a/app-crypt/gpgstats/files/gpgstats-0.5-flags.patch b/app-crypt/gpgstats/files/gpgstats-0.5-flags.patch
new file mode 100644
index 000000000000..018d97390c65
--- /dev/null
+++ b/app-crypt/gpgstats/files/gpgstats-0.5-flags.patch
@@ -0,0 +1,25 @@
+--- Makefile
++++ Makefile
+@@ -1,16 +1,18 @@
+ VERSION=0.5
+
+ DEBUG=-g # -fprofile-arcs -ftest-coverage # -pg -g
+-CXXFLAGS+=-Wall -O2 -DVERSION=\"${VERSION}\" $(DEBUG) `gpgme-config --cflags`
+-CFLAGS+=${CXXFLAGS}
+-LDFLAGS=-lstdc++ `gpgme-config --libs` $(DEBUG)
++CPPFLAGS+=-DVERSION=\"${VERSION}\" -D_FILE_OFFSET_BITS=64
++FLAGS+=-Wall $(DEBUG) `gpgme-config --cflags`
++CFLAGS+=${FLAGS}
++CXXFLAGS+=${FLAGS}
++LIBS=`gpgme-config --libs`
+
+ OBJS=error.o utils.o array.o iarray.o s.o
+
+ all: gpgstats
+
+ gpgstats: $(OBJS)
+- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o gpgstats
++ $(CXX) $(LDFLAGS) -Wall -W $(OBJS) -o gpgstats $(LIBS)
+
+ install: gpgstats
+ cp gpgstats /usr/bin
diff --git a/app-crypt/gpgstats/gpgstats-0.5-r1.ebuild b/app-crypt/gpgstats/gpgstats-0.5-r1.ebuild
new file mode 100644
index 000000000000..f10306f88613
--- /dev/null
+++ b/app-crypt/gpgstats/gpgstats-0.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GPGstats calculates statistics on the keys in your key-ring"
+HOMEPAGE="http://www.vanheusden.com/gpgstats/"
+SRC_URI="http://www.vanheusden.com/gpgstats/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-crypt/gpgme"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-flags.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" DEBUG= || die "emake failed"
+}
+
+src_install() {
+ dobin gpgstats || die "dobin gpgstas failed"
+}
diff --git a/app-crypt/gpgstats/metadata.xml b/app-crypt/gpgstats/metadata.xml
new file mode 100644
index 000000000000..f08d14f4a08f
--- /dev/null
+++ b/app-crypt/gpgstats/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>