summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-29 22:25:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-29 22:25:53 +0300
commit63f483a11ab26e5faf057998d83c22b3e647c64f (patch)
treef80a71640be89b2031642e4d06d3f0c3921d458e /app-containers
parentapp-containers/nerdctl: add 1.7.6 (diff)
downloadgentoo-63f483a11ab26e5faf057998d83c22b3e647c64f.tar.gz
gentoo-63f483a11ab26e5faf057998d83c22b3e647c64f.tar.bz2
gentoo-63f483a11ab26e5faf057998d83c22b3e647c64f.zip
app-containers/nerdctl: drop 1.7.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/nerdctl/Manifest2
-rw-r--r--app-containers/nerdctl/nerdctl-1.7.4.ebuild53
2 files changed, 0 insertions, 55 deletions
diff --git a/app-containers/nerdctl/Manifest b/app-containers/nerdctl/Manifest
index 3e91fdafb8e1..e1163e8c602d 100644
--- a/app-containers/nerdctl/Manifest
+++ b/app-containers/nerdctl/Manifest
@@ -1,5 +1,3 @@
-DIST nerdctl-1.7.4-go-mod-vendor.tar.gz 7197938 BLAKE2B 14a95cd634acc652d5532d1c6aa28abf24c1cf26393d63fd627e864ba73e5f3355832afd8c3c31eb0dcef9ae1d82c35a7df49c017c5719b45145496ec9243e79 SHA512 aefc9d23114bb2ca0a640287ed27e2afeeb9075a4fdfa33817310300ac8a1ca492defd4a5436f71f4f06a2b8916a75793ce846eac0878a8e51e1accadd21d13f
-DIST nerdctl-1.7.4.tar.gz 516231 BLAKE2B 3f1726945c5b816b4ca922187ae0bde0af82ca38227fe3ad2509b8b1654a2ee22d3929296d9633275cc7c3495202c66d90a956ac92c790f17eb2d1254bdb2c17 SHA512 a2cf60e2d704bef6a9c2abc697ef44a6a833b5fcc276bbffec503437281c830e2cd73fc541ef85be2444bad8f2b827c832b7685a3c74ebba503019ed39a19d75
DIST nerdctl-1.7.5-go-mod-vendor.tar.gz 7229228 BLAKE2B 24dd81b3b54542e8723c44d75e653414c75be9e0e56095e7afe6886d2bde6febdc91b7ef903009145c77a57dd4780bbceda58851b39e7375141066abc20f2f1f SHA512 265d9ae58ec221611c9f7666de2748bf8519a7ba8b3bc0bd3b1e97d671bfc11c7d51cd4512d52000a579c8f5e4bd7e4c5a4bf469853b481c838262001bd9dd65
DIST nerdctl-1.7.5.tar.gz 517127 BLAKE2B 800fc487c60ea62641b26a1b41f95747bd39467d8e1c7fd7b5302c5d515c2e6765fcf7ef8860b3cbfe04428fe849a7293ec914bae3da65ac6418a1f5c789d832 SHA512 3e35c5e3c68c675d23c1a106d267f62c2e36cd8026308ac6237fa5aa2f3ebaea0f47888e6702290f40c26f543e90bca91d76cae28b74732e8fb351f6ef2441f9
DIST nerdctl-1.7.6-go-mod-vendor.tar.gz 7224842 BLAKE2B 65b06708bd9e568a58f486af7e1f47f4118543158035437f6145bba8221963e13014baeb16e16e0c038ca9b3b1109437594b92d25036779634d4c0360bd84595 SHA512 62e0dce2480c3f50c2f9473864294e36ee09bcb0b5f0e9655c1995f7067b6feb6d379a5f6331dde0e1f5bd1f673e0b172d96edf060167cc17cf2ec8a38cfeafa
diff --git a/app-containers/nerdctl/nerdctl-1.7.4.ebuild b/app-containers/nerdctl/nerdctl-1.7.4.ebuild
deleted file mode 100644
index 43a574817df7..000000000000
--- a/app-containers/nerdctl/nerdctl-1.7.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-EGIT_COMMIT="7b5f7e0d8f705ed4e54f7040512327e231433366"
-
-DESCRIPTION="Docker-compatible CLI for containerd, with support for Compose"
-HOMEPAGE="https://github.com/containerd/nerdctl"
-SRC_URI="
- https://github.com/containerd/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/containerd/${PN}/releases/download/v${PV}/${P}-go-mod-vendor.tar.gz
-"
-
-LICENSE="Apache-2.0"
-LICENSE+=" BSD BSD-2 ISC MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="rootless"
-
-DEPEND="
- rootless? (
- app-containers/slirp4netns
- sys-apps/rootlesskit
- )
-"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack "${P}.tar.gz"
- cd "${S}"
- unpack "${P}-go-mod-vendor.tar.gz"
-}
-
-src_compile() {
- emake VERSION=v${PV} REVISION="${EGIT_COMMIT}"
-}
-
-src_install() {
- local emake_args=(
- DESTDIR="${D}"
- VERSION=v${PV}
- REVISION="${EGIT_COMMIT}"
- DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
- PREFIX="${EPREFIX}/usr"
- install
- )
- emake "${emake_args[@]}"
- DOCS=( README.md docs/* examples )
- einstalldocs
-}