summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-05-11 16:23:47 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-05-11 16:23:51 -0500
commitcc576ef164959ceb193b083706f6d5dd0bf70acb (patch)
tree02fd296605f6934ce3a746bfc0b54fe53b2aa5c2 /app-containers/syft
parentapp-containers/grype: initial import (diff)
downloadgentoo-cc576ef164959ceb193b083706f6d5dd0bf70acb.tar.gz
gentoo-cc576ef164959ceb193b083706f6d5dd0bf70acb.tar.bz2
gentoo-cc576ef164959ceb193b083706f6d5dd0bf70acb.zip
app-containers/syft: initial import
Syft is a CLI tool and library for generating a Software Bill of Materials from container images and filesystems Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/syft')
-rw-r--r--app-containers/syft/Manifest2
-rw-r--r--app-containers/syft/metadata.xml8
-rw-r--r--app-containers/syft/syft-0.45.1.ebuild22
3 files changed, 32 insertions, 0 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
new file mode 100644
index 000000000000..9b3293a93e5f
--- /dev/null
+++ b/app-containers/syft/Manifest
@@ -0,0 +1,2 @@
+DIST syft-0.45.1-deps.tar.xz 619145524 BLAKE2B c39ce29edb6820ff620f2d25b564084b2328f24cd453aad0cfed3a799768ff5e18f6de2fd11d981c544b6f377bb8ef64433158c71cab63c184587e648ab6bae0 SHA512 f734266b51956543e2aa94b62d47abeb45fa63de31b4f2d2d6e084b2c9233a1a0dbd36890523f54836d4e341c6fb38c3a2a0aca775a8ce2ca2bf3672e7dfbd72
+DIST syft-0.45.1.tar.gz 3826388 BLAKE2B 9600f44d4d0390c2cda422ccec04ab8f27165ed00cb031dfc441e21a156f5abfb1e63ed26bbc5795b074d2b8f578486624f8a88c87248a5c70a02268d728bbf2 SHA512 938af62b5c9d724d206db98174892bede409f4bfb9199d636cf3cedfa605cc79f2e4d9c2b49868e4f9ac1ab64d05b42849d15c9f28bf4c7a2b531449f346ef85
diff --git a/app-containers/syft/metadata.xml b/app-containers/syft/metadata.xml
new file mode 100644
index 000000000000..3b2a9c591010
--- /dev/null
+++ b/app-containers/syft/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>williamh@gentoo.org</email>
+<name>William Hubbs</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-containers/syft/syft-0.45.1.ebuild b/app-containers/syft/syft-0.45.1.ebuild
new file mode 100644
index 000000000000..2c42d972b97c
--- /dev/null
+++ b/app-containers/syft/syft-0.45.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o bin/syft ./cmd/syft
+}
+
+src_install() {
+dobin bin/*
+}