summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/upx-ucl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/upx-ucl')
-rw-r--r--app-arch/upx-ucl/Manifest2
-rw-r--r--app-arch/upx-ucl/metadata.xml11
-rw-r--r--app-arch/upx-ucl/upx-ucl-3.91.ebuild44
3 files changed, 57 insertions, 0 deletions
diff --git a/app-arch/upx-ucl/Manifest b/app-arch/upx-ucl/Manifest
new file mode 100644
index 000000000000..c92b232e2a7e
--- /dev/null
+++ b/app-arch/upx-ucl/Manifest
@@ -0,0 +1,2 @@
+DIST lzma465.tar.bz2 288122 SHA256 c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e SHA512 690f005cfa9d3a65db03baddad57cf8dd79f861ac72d2e1bc18a151f3673d5f8043e3331f5dc3fba713dfd7b01ebf0817a2c0b6a1b22e1f7d8255a42b85ea4ac WHIRLPOOL 34a08888ac6874c1ac4ff181774b02eec993cc90a28531596122183c975c2e29fd9852d066acd24c0fe1f213ae9e03e7daf3fc9417c587043e968d973551027f
+DIST upx-3.91-src.tar.bz2 904747 SHA256 527ce757429841f51675352b1f9f6fc8ad97b18002080d7bf8672c466d8c6a3c SHA512 7e9a392fe11daf7baf9632f2c448ef9936da7dfab215f86ba417e9f097770949acb653aaabe6cc5ed812efc486cb35e0c1e128c80026b02825713d8b12251cf5 WHIRLPOOL 1e20491528c9c7da50985c4484c0062799a243adebfd8292ea3c136b93d865842e85e164e15f1005d0e821b83aa7162e7113553cafd5f0b584d9b08aa6c7938e
diff --git a/app-arch/upx-ucl/metadata.xml b/app-arch/upx-ucl/metadata.xml
new file mode 100644
index 000000000000..0fc231e1b2bf
--- /dev/null
+++ b/app-arch/upx-ucl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>UPX is a versatile executable packer with a excellent compression ratio</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">sevenzip</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/upx-ucl/upx-ucl-3.91.ebuild b/app-arch/upx-ucl/upx-ucl-3.91.ebuild
new file mode 100644
index 000000000000..3f47c3176e29
--- /dev/null
+++ b/app-arch/upx-ucl/upx-ucl-3.91.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+LZMA_VER=465
+#LZMA_VER=920
+MY_P="${P/-ucl}-src"
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="http://upx.sourceforge.net/"
+SRC_URI="http://upx.sourceforge.net/download/${MY_P}.tar.bz2
+ lzma? ( mirror://sourceforge/sevenzip/lzma${LZMA_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="lzma zlib"
+
+RDEPEND=">=dev-libs/ucl-1.02
+ !app-arch/upx
+ !app-arch/upx-bin"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ use zlib && append-cppflags -DWITH_ZLIB=1
+}
+
+src_compile() {
+ tc-export CXX
+ emake UPX_LZMADIR="${WORKDIR}" all
+}
+
+src_install() {
+ newbin src/upx.out upx
+ dodoc BUGS NEWS PROJECTS README* THANKS TODO doc/*.txt
+ dohtml doc/upx.html
+ doman doc/upx.1
+}