summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-04-24 13:55:03 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-04-24 13:55:14 +0200
commite7660d41c70d1c01a0bbd06ecbaad3be2a8968d4 (patch)
treeb9b40d427973f2fa2bd8c15c45e8274b6211923b /app-arch/rpm2targz
parentnet-libs/libtorrent-rasterbar: Version bump (v1.2.6) (diff)
downloadgentoo-e7660d41c70d1c01a0bbd06ecbaad3be2a8968d4.tar.gz
gentoo-e7660d41c70d1c01a0bbd06ecbaad3be2a8968d4.tar.bz2
gentoo-e7660d41c70d1c01a0bbd06ecbaad3be2a8968d4.zip
app-arch/rpm2targz: add zstd support
Closes: https://bugs.gentoo.org/719208 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-arch/rpm2targz')
-rw-r--r--app-arch/rpm2targz/files/rpm2targz-9.0.0.5g-add-zstd-support.patch20
-rw-r--r--app-arch/rpm2targz/rpm2targz-9.0.0.5g-r2.ebuild30
2 files changed, 50 insertions, 0 deletions
diff --git a/app-arch/rpm2targz/files/rpm2targz-9.0.0.5g-add-zstd-support.patch b/app-arch/rpm2targz/files/rpm2targz-9.0.0.5g-add-zstd-support.patch
new file mode 100644
index 000000000000..085c61aa4e71
--- /dev/null
+++ b/app-arch/rpm2targz/files/rpm2targz-9.0.0.5g-add-zstd-support.patch
@@ -0,0 +1,20 @@
+Origin: https://bugs.gentoo.org/719208
+Author: Rafał Mużyło
+
+--- a/rpmoffset.c
++++ b/rpmoffset.c
+@@ -58,11 +58,13 @@ int is_magic_lzma(const char *buf)
+ static const unsigned char magic_gzip[] = { '\037', '\213', '\010' };
+ static const unsigned char magic_bzip2[] = { 'B', 'Z', 'h' };
+ static const unsigned char magic_xz[] = { 0xFD, '7', 'z', 'X', 'Z', 0x00 };
++static const unsigned char magic_zstd[] = { 0x28, 0xB5, 0x2F, 0xFD };
+ static const magic_t magics[] = {
+ #define DECLARE_MAGIC_T(t) { .type = #t, .magic = magic_##t, .len = sizeof(magic_##t), },
+ DECLARE_MAGIC_T(gzip)
+ DECLARE_MAGIC_T(bzip2)
+ DECLARE_MAGIC_T(xz)
++ DECLARE_MAGIC_T(zstd)
+ #undef DECLARE_MAGIC_T
+ };
+ #define MAGIC_SIZE_MIN 3
+
diff --git a/app-arch/rpm2targz/rpm2targz-9.0.0.5g-r2.ebuild b/app-arch/rpm2targz/rpm2targz-9.0.0.5g-r2.ebuild
new file mode 100644
index 000000000000..6bc46a104cbd
--- /dev/null
+++ b/app-arch/rpm2targz/rpm2targz-9.0.0.5g-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert a .rpm file to a .tar.gz archive"
+HOMEPAGE="http://www.slackware.com/config/packages.php"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/cpio
+ app-arch/zstd"
+
+PATCHES=( "${FILESDIR}"/${PN}-9.0.0.5g-add-zstd-support.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install # need explicit install line #397835
+ dodoc *.README*
+}