summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/pxz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/pxz')
-rw-r--r--app-arch/pxz/Manifest1
-rw-r--r--app-arch/pxz/metadata.xml16
-rw-r--r--app-arch/pxz/pxz-5.0_pre20110811.ebuild25
-rw-r--r--app-arch/pxz/pxz-9999.ebuild44
4 files changed, 86 insertions, 0 deletions
diff --git a/app-arch/pxz/Manifest b/app-arch/pxz/Manifest
new file mode 100644
index 000000000000..a779dd0254f6
--- /dev/null
+++ b/app-arch/pxz/Manifest
@@ -0,0 +1 @@
+DIST pxz-5.0_pre20110811.tar.xz 11192 SHA256 0059ce89a35ed9d14634903ba1c7aae0a4af6116a6b0f04e10c4602862690ad7 SHA512 d7a837a1b777aad397752efdb0416778bd7b0da93db40528db384b5573702ff9c387c8223a65d1cdec3261cad07ca51ba8dc3bd8be18871d66f63009e144799d WHIRLPOOL f6b9dee63c2888f360f6298b04fb8d58ff20d57838faefa7e96296a37a98263d42b414380820642c9fc57d8ca4f5ff6d1eb7ddca66d09943c2676bf34b0e3a01
diff --git a/app-arch/pxz/metadata.xml b/app-arch/pxz/metadata.xml
new file mode 100644
index 000000000000..f33d0ac2ad6e
--- /dev/null
+++ b/app-arch/pxz/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>chutzpah@gentoo.org</email>
+<name>Patrick McLean</name>
+</maintainer>
+<longdescription lang="en">
+Parallel XZ is a compression utility that takes advantage of running LZMA
+compression of different parts of an input file on multiple cores and
+processors simultaneously. Its primary goal is to utilize all resources
+to speed up compression time with minimal possible influence on compression
+ratio.
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-arch/pxz/pxz-5.0_pre20110811.ebuild b/app-arch/pxz/pxz-5.0_pre20110811.ebuild
new file mode 100644
index 000000000000..125750290860
--- /dev/null
+++ b/app-arch/pxz/pxz-5.0_pre20110811.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit flag-o-matic
+
+DESCRIPTION="Parallel implementation of the XZ compression utility"
+HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ sys-devel/gcc[openmp]"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}
diff --git a/app-arch/pxz/pxz-9999.ebuild b/app-arch/pxz/pxz-9999.ebuild
new file mode 100644
index 000000000000..923d40ee5361
--- /dev/null
+++ b/app-arch/pxz/pxz-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit toolchain-funcs flag-o-matic
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/jnovy/pxz.git"
+ inherit git-2
+else
+ MY_PV=${PV/_}
+ case ${MY_PV} in
+ *beta?*) MY_PV="${MY_PV/beta/beta.}git" ;;
+ esac
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="http://jnovy.fedorapeople.org/pxz/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P/beta*/beta}
+fi
+
+DESCRIPTION="parallel LZMA compressor (no parallel decompression!)"
+HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# needs the library from xz-utils
+# needs the libgomp library from gcc at runtime
+DEPEND="app-arch/xz-utils
+ sys-devel/gcc[openmp]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ append-lfs-flags
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}