summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-07 11:38:15 +0000
committerSam James <sam@gentoo.org>2023-03-07 11:38:15 +0000
commitb4386cdacf80445dd7e9820b8f58fa7254bcdd0c (patch)
tree99fe6d99389f6964107fc085497ca88bb6d408c2 /app-admin
parentsys-libs/libcap-ng: enable py3.11 (diff)
downloadgentoo-b4386cdacf80445dd7e9820b8f58fa7254bcdd0c.tar.gz
gentoo-b4386cdacf80445dd7e9820b8f58fa7254bcdd0c.tar.bz2
gentoo-b4386cdacf80445dd7e9820b8f58fa7254bcdd0c.zip
app-admin/webapp-config: enable py3.11
Closes: https://bugs.gentoo.org/896488 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r2.ebuild22
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild12
2 files changed, 20 insertions, 14 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.55-r2.ebuild b/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
index 9ef0f49f155f..9aad95348cfe 100644
--- a/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
@@ -4,12 +4,18 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 prefix
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://anongit.gentoo.org/proj/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
DESCRIPTION="Gentoo's installer for web-based applications"
HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
@@ -32,6 +38,11 @@ python_compile_all() {
emake -C doc/
}
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
python_install() {
# According to this discussion:
# http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
@@ -54,11 +65,6 @@ python_install_all() {
doman doc/*.[58]
}
-python_test() {
- PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
- die "Testing failed with ${EPYTHON}"
-}
-
pkg_postinst() {
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 80bc77e30465..9aad95348cfe 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 prefix
@@ -38,6 +38,11 @@ python_compile_all() {
emake -C doc/
}
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
python_install() {
# According to this discussion:
# http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
@@ -60,11 +65,6 @@ python_install_all() {
doman doc/*.[58]
}
-python_test() {
- PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
- die "Testing failed with ${EPYTHON}"
-}
-
pkg_postinst() {
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"