summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-12-01 16:45:07 -0800
committerJohn Helmert III <ajak@gentoo.org>2024-12-01 16:45:07 -0800
commit9d95292d0123ecd74a4291661ad51b272c324cee (patch)
tree4a5ac1462ca695142e301f27d09a52248c580e6a /app-admin
parentnet-p2p/arti: add 1.3.0 (diff)
downloadgentoo-9d95292d0123ecd74a4291661ad51b272c324cee.tar.gz
gentoo-9d95292d0123ecd74a4291661ad51b272c324cee.tar.bz2
gentoo-9d95292d0123ecd74a4291661ad51b272c324cee.zip
app-admin/gopass: add 1.15.15
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gopass/Manifest2
-rw-r--r--app-admin/gopass/gopass-1.15.15.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/gopass/Manifest b/app-admin/gopass/Manifest
index 1245f7dd8d15..c12ecc15c924 100644
--- a/app-admin/gopass/Manifest
+++ b/app-admin/gopass/Manifest
@@ -2,3 +2,5 @@ DIST gopass-1.15.13-deps.tar.xz 284979668 BLAKE2B 12e42b897dfc613de810cc4c42e231
DIST gopass-1.15.13.tar.gz 2328529 BLAKE2B 276ea675c7978ac1627cb313b595d9f252cc3aae29245eca758aed3b6632ddcdfa0da93cdc06f4c0767a2d5f58ded41fcccfac774b5001351bb4b743e976c595 SHA512 b7fcc7814ccad0cf0e3116eac848df080338e313ddcbb0cc8413cb353a1596b250aed427c97e791326e04c6c4241dbb529e112398218f2a905fc0fb48bc49963
DIST gopass-1.15.14-deps.tar.xz 129535712 BLAKE2B efb790782a25d6f22b3b5f8b747bd72ea8f487bac18e7da746ebefd159a1ae6e36930d6bfe9b000c5d4096d9bbf277f9e263e922a57094d0d337bdd3add65a97 SHA512 88c27326563a3b3d35e05a31fde3d563a6d5c3ee67eb36580b4723c3b2646cc2662b2c8c77e1e2db9edaa8c25e73fa390fc08d98524a66f6b99a0fa8a84303b3
DIST gopass-1.15.14.tar.gz 2328921 BLAKE2B 76d58f43cd0d95743a3160ec1eae372a4e26e58483a4685b41fa8b8845a1b2adbb3f0be61e23523558eb96a9d10af4b43f5610ba7f44cb5736b944d97a4f7b6e SHA512 874ea69816df46bc03113cbc3f1fae5b9c08a9c0b09a566097163f2f03f97e5d256351432f0f0eb1f89c5643b5866b4800e986d344f6fe06c5c3d4b3721c0521
+DIST gopass-1.15.15-deps.tar.xz 132123176 BLAKE2B 9ae5d2fe422162cedfa2b0e031885efe8f2fdc03de4d9d8698033554bbbb99eb7602834f7f1e107677b054264151cf62f8ff8349713e49e55d2489c2275d47d6 SHA512 33d0d60e9f020edccffd8c2bb71d2f038dd0d5ddca012a19ab47a4efc172660ae13d77283bc2103cf7466353d52a461a15b84309f1e1781ecd00b35db4bb5b25
+DIST gopass-1.15.15.tar.gz 2335086 BLAKE2B a871decc50024cee032ed2d494da05ea6443de500138a0067120fd070c7797e03e81676edbeb71301a503a13644cc1878c702ffa72a970a835f59543941b75b0 SHA512 f5949d0e21ce7e9de9ae8d89e2371ed4fe0c2ffbb112f9529b8e6361a327c2692e1355b50f8f962c333e2ce397ba024b5ac90b4239851905c67baf3e363b1737
diff --git a/app-admin/gopass/gopass-1.15.15.ebuild b/app-admin/gopass/gopass-1.15.15.ebuild
new file mode 100644
index 000000000000..bac64dde98cc
--- /dev/null
+++ b/app-admin/gopass/gopass-1.15.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature
+
+DESCRIPTION="a simple but powerful password manager for the terminal"
+HOMEPAGE="https://www.gopass.pw/"
+SRC_URI="https://github.com/gopasspw/gopass/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND=">=dev-lang/go-1.18"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.15.3-skip-tests.patch"
+)
+
+src_test() {
+ # https://github.com/gopasspw/gopass/blob/v1.15.3/.github/workflows/build.yml#L38
+ git config --global user.name nobody || die
+ git config --global user.email foo.bar@example.org || die
+
+ default
+}
+
+src_install() {
+ emake install DESTDIR="${ED}/usr"
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "browser integration" app-admin/gopass-jsonapi
+ optfeature "git credentials helper" app-admin/git-credential-gopass
+ optfeature "haveibeenpwnd.com integration" app-admin/gopass-hibp
+ optfeature "summon secrets helper" app-admin/gopass-summon-provider
+}