summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-03-09 18:28:57 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-03-10 07:58:30 +0000
commit47100386df4c34efab034aff907f85a88ab18375 (patch)
tree1892eb7ccc3f35dc07bda82eb546ca5778bb396b /app-admin
parentkde-apps/kig: fix build with USE="scripting" (diff)
downloadgentoo-47100386df4c34efab034aff907f85a88ab18375.tar.gz
gentoo-47100386df4c34efab034aff907f85a88ab18375.tar.bz2
gentoo-47100386df4c34efab034aff907f85a88ab18375.zip
app-admin/ulogd: verbump to 2.0.5_p20160205
This commit closes #1014. Snapshot verbump to get the fix [1] for the upstream bug #1030 [2] (unsafe signal handling). Quote from the commit message of the mentioned fix: This patch will solve various symptoms like following. - Deadlock - Segmentation fault caused by libc management data corruption, - Other unpredictable behavior. End quote. Also other minor fixes here and there. [1]: https://git.netfilter.org/ulogd2/commit/?id=1f70d2ba45e2b067777d5386b8d3f2e09be9118b [2]: https://bugzilla.netfilter.org/show_bug.cgi?id=1030 Pull-Request: https://github.com/gentoo/gentoo/pull/1014 Acked-by: Patrice Clement <monsieurp@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: portage-2.2.27
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ulogd/Manifest1
-rw-r--r--app-admin/ulogd/ulogd-2.0.5_p20160205.ebuild (renamed from app-admin/ulogd/ulogd-2.0.5-r4.ebuild)29
2 files changed, 11 insertions, 19 deletions
diff --git a/app-admin/ulogd/Manifest b/app-admin/ulogd/Manifest
index d969037d459d..125ea5cc39f1 100644
--- a/app-admin/ulogd/Manifest
+++ b/app-admin/ulogd/Manifest
@@ -1 +1,2 @@
DIST ulogd-2.0.5.tar.bz2 456258 SHA256 a221cb9f77347c0ca00d0937e27c1b90e3291a553cc62a4139b788e2e420e8c0 SHA512 bf00b8adaad7bd04077a83521b0d7accc26e644c8f3386819e7f91476178b6733f1c6554fb82dd0d3913398c83a61d65f61dc973f199f610bfaadc6251504819 WHIRLPOOL fe499ac7b4070581439a05f4f2245f7a42fe5630da5dc32b9b069511ed1faa15fe482eee08d50477d3fb1d0bf0d3855a69fc82fb0f3e8eecdf082fb642519f91
+DIST ulogd-2.0.5_p20160205.tar.gz 137899 SHA256 d6ece155270aaaea2f78740c00ae679f04e42fd90b4b7c2f342c2dddeb414ee4 SHA512 99c824fcb404f2f4d7b1bd4d8c9231a1a61121f9ae88901d8d30b33172c1f24e44abd37c30ea71722078b543b58c57a6bc99d64e2a655a5af73fe6edf37c72ab WHIRLPOOL 5c3013fc0b0b8d9209d69aac2b25255c9067167ae3c66a73a36f0ee391dc1b6b482f36b786aa57f361c19d5d26da99ab376c3093c460bc02f3764276e0e7f77a
diff --git a/app-admin/ulogd/ulogd-2.0.5-r4.ebuild b/app-admin/ulogd/ulogd-2.0.5_p20160205.ebuild
index 9c28d08340ac..af80b24aec58 100644
--- a/app-admin/ulogd/ulogd-2.0.5-r4.ebuild
+++ b/app-admin/ulogd/ulogd-2.0.5_p20160205.ebuild
@@ -5,15 +5,13 @@
EAPI=5
AUTOTOOLS_AUTORECONF=1
+COMMIT_ID="a82d9cfe03679b82ab4d9586c93ad377e9e27149"
-inherit autotools-utils eutils flag-o-matic linux-info readme.gentoo-r1 systemd user
+inherit autotools-utils eutils flag-o-matic linux-info readme.gentoo-r1 systemd user vcs-snapshot
DESCRIPTION="A userspace logging daemon for netfilter/iptables related logging"
HOMEPAGE="https://netfilter.org/projects/ulogd/index.html"
-SRC_URI="
- https://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2
- ftp://ftp.netfilter.org/pub/${PN}/${P}.tar.bz2
-"
+SRC_URI="https://git.netfilter.org/${PN}2/snapshot/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -46,11 +44,9 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS README TODO )
-PATCHES=( "${FILESDIR}/${P}-remove-db-automagic.patch" )
-
DOC_CONTENTS="
You must have at least one logging stack enabled to make ulogd work.
- Please edit example configuration located at /etc/ulogd.conf
+ Please edit the example configuration located at /etc/ulogd.conf.
"
pkg_setup() {
@@ -60,21 +56,16 @@ pkg_setup() {
linux-info_pkg_setup
if kernel_is lt 2 6 14; then
- die "ulogd requires kernel newer than 2.6.14"
- fi
-
- if kernel_is lt 2 6 18; then
- ewarn "You are using kernel older than 2.6.18"
- ewarn "Some ulogd features may be unavailable"
+ die "${PN} requires a kernel >= 2.6.14."
fi
if use nfacct && kernel_is lt 3 3 0; then
- ewarn "NFACCT input plugin requires kernel newer than 3.3.0"
+ ewarn "NFACCT input plugin requires a kernel >= 3.3."
fi
- if use ulog && kernel_is gt 3 17 0; then
- ewarn "ULOG target was removed since 3.17.0 kernel release"
- ewarn "Consider enabling NFACCT, NFCT or NFLOG support"
+ if use ulog && kernel_is ge 3 17 0; then
+ ewarn "ULOG target has been removed in the 3.17 kernel release."
+ ewarn "Consider enabling NFACCT, NFCT, or NFLOG support instead."
fi
}
@@ -82,7 +73,7 @@ src_prepare() {
# - make all logs to be kept in a single dir /var/log/ulogd
# - place sockets in /run instead of /tmp
sed -i \
- -e 's%var/log%var/log/ulogd%g' \
+ -e "s%var/log%var/log/${PN}%g" \
-e 's%tmp%run%g' \
ulogd.conf.in || die