summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-03-21 16:54:34 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-21 16:54:34 -0500
commit2a13095e21dde5566860ec6f758348327aebe5da (patch)
tree5e0a88375df9aade60c497f6d32d4b6e40c21159 /app-admin
parentapp-pda/libusbmuxd: Version bump to 2.0.1 (diff)
downloadgentoo-2a13095e21dde5566860ec6f758348327aebe5da.tar.gz
gentoo-2a13095e21dde5566860ec6f758348327aebe5da.tar.bz2
gentoo-2a13095e21dde5566860ec6f758348327aebe5da.zip
app-admin/terraform: 0.12.24 general cleanups
-drop the use of golang-base - clean up src_prepare since it was all comments Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/terraform/terraform-0.12.24.ebuild15
1 files changed, 2 insertions, 13 deletions
diff --git a/app-admin/terraform/terraform-0.12.24.ebuild b/app-admin/terraform/terraform-0.12.24.ebuild
index 02737dda10ce..3fd839630186 100644
--- a/app-admin/terraform/terraform-0.12.24.ebuild
+++ b/app-admin/terraform/terraform-0.12.24.ebuild
@@ -3,12 +3,10 @@
EAPI=7
-inherit golang-base go-module
+inherit go-module
DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
HOMEPAGE="https://www.terraform.io/"
-
-EGO_PN="github.com/hashicorp/${PN}"
SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
@@ -19,17 +17,8 @@ RESTRICT="test"
DOCS=( {README,CHANGELOG}.md )
-src_prepare() {
- default
- # the sed command is necessary to generate tests outside of the
- # default git root of `terraform', in our case the working dir
- # is `work/$PN-$PV'
- # sed -i -e "s/!=\s\+\"terraform\"/!=\ \"${P}\"/" \
- # ./scripts/generate-plugins.go || die
-}
-
src_compile() {
- GOCACHE="${T}/go-cache" go build \
+ go build \
-mod vendor \
-work -o "bin/${PN}" ./ || die
}