summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/pwgen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/pwgen')
-rw-r--r--app-admin/pwgen/Manifest1
-rw-r--r--app-admin/pwgen/files/2.06-special-char.patch11
-rw-r--r--app-admin/pwgen/files/pwgen.rc19
-rw-r--r--app-admin/pwgen/metadata.xml14
-rw-r--r--app-admin/pwgen/pwgen-2.07.ebuild29
5 files changed, 74 insertions, 0 deletions
diff --git a/app-admin/pwgen/Manifest b/app-admin/pwgen/Manifest
new file mode 100644
index 000000000000..2895c677b65d
--- /dev/null
+++ b/app-admin/pwgen/Manifest
@@ -0,0 +1 @@
+DIST pwgen-2.07.tar.gz 53513 SHA256 eb74593f58296c21c71cd07933e070492e9222b79cedf81d1a02ce09c0e11556 SHA512 9c56ff04ca2f6f60126608a25f395ddbc4a3ac59585a6f233c87d993b6388e30b1867d43a6bc5b0f9f1f4064b12ea450eac4f7c9ac2844707a99fad1bbd2664d WHIRLPOOL b1c7b543efd552ebd2db83ada501093d7ee03d6975df4a81255540b2b84817ef9b8abcf287cbc2500773987bb416946afc7104edaaa06400b76d7bc68db55469
diff --git a/app-admin/pwgen/files/2.06-special-char.patch b/app-admin/pwgen/files/2.06-special-char.patch
new file mode 100644
index 000000000000..3d014fa4bf11
--- /dev/null
+++ b/app-admin/pwgen/files/2.06-special-char.patch
@@ -0,0 +1,11 @@
+--- a/pwgen.c
++++ b/pwgen.c
+@@ -138,7 +138,7 @@ int main(int argc, char **argv)
+ break;
+ case 's':
+ pwgen = pw_rand;
+- pwgen_flags = PW_DIGITS | PW_UPPERS;
++ pwgen_flags |= PW_DIGITS | PW_UPPERS;
+ break;
+ case 'C':
+ do_columns = 1;
diff --git a/app-admin/pwgen/files/pwgen.rc b/app-admin/pwgen/files/pwgen.rc
new file mode 100644
index 000000000000..424ea2dd7412
--- /dev/null
+++ b/app-admin/pwgen/files/pwgen.rc
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ before local
+}
+
+start() {
+ ebegin "Auto-scrambling root password for security"
+ echo root:`pwgen -s 16` | chpasswd > /dev/null 2>&1
+ eend $? "Failed to scramble root password."
+}
+
+stop() {
+ ebegin "Stopping pwgen"
+ eend $? "Failed to stop pwgen."
+}
diff --git a/app-admin/pwgen/metadata.xml b/app-admin/pwgen/metadata.xml
new file mode 100644
index 000000000000..11dddfb5251a
--- /dev/null
+++ b/app-admin/pwgen/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>livecd</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="livecd">Install init script for root password scrambling on boot</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">pwgen</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/pwgen/pwgen-2.07.ebuild b/app-admin/pwgen/pwgen-2.07.ebuild
new file mode 100644
index 000000000000..4d652df71aab
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.07.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Password Generator"
+HOMEPAGE="http://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="livecd"
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.06-special-char.patch
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/etc/pwgen
+}
+
+src_install() {
+ default
+ use livecd && newinitd "${FILESDIR}"/pwgen.rc pwgen
+}