summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-07 23:34:40 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-07 23:41:11 +0100
commitc423d5828bbe34733d2e61e43a8634cd59985c4e (patch)
tree21fc97c6854ed48e92da44bb24f7cc0320899099 /app-admin/keepassxc
parentapp-admin/keepassxc: Revbump to depend on x11-misc/xsel (diff)
downloadgentoo-c423d5828bbe34733d2e61e43a8634cd59985c4e.tar.gz
gentoo-c423d5828bbe34733d2e61e43a8634cd59985c4e.tar.bz2
gentoo-c423d5828bbe34733d2e61e43a8634cd59985c4e.zip
app-admin/keepassxc: Updated live ebuild.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild34
1 files changed, 22 insertions, 12 deletions
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 69a100508278..1b5f2654570d 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -1,17 +1,22 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils gnome2-utils xdg-utils
+inherit cmake-utils xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"
if [[ "${PV}" != 9999 ]] ; then
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ if [[ "${PV}" == *_beta* ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ fi
else
inherit git-r3
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
@@ -47,6 +52,11 @@ DEPEND="
dev-qt/qtconcurrent:5
"
+# Not a runtime dependency but still needed (see bug #667092)
+PDEPEND="
+ x11-misc/xsel
+"
+
src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
@@ -68,14 +78,14 @@ src_configure() {
cmake-utils_src_configure
}
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+ xdg_pkg_postinst
}
pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+ xdg_pkg_postrm
}