summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-11 19:36:46 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-25 13:03:52 +0200
commit92278a6521c82c8f3cfcf0053c5487662d122c95 (patch)
treedc506fe641f3f300918572cfc48357e74bdda7f5 /app-admin/clustershell
parentmedia-gfx/aewan: EAPI bump, fix build for clang16 (diff)
downloadgentoo-92278a6521c82c8f3cfcf0053c5487662d122c95.tar.gz
gentoo-92278a6521c82c8f3cfcf0053c5487662d122c95.tar.bz2
gentoo-92278a6521c82c8f3cfcf0053c5487662d122c95.zip
app-admin/clustershell: add 1.9.1
Man pages are newly installed by setup.py. Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29549 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/clustershell')
-rw-r--r--app-admin/clustershell/Manifest1
-rw-r--r--app-admin/clustershell/clustershell-1.9.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/clustershell/Manifest b/app-admin/clustershell/Manifest
index 698b8397c656..033fde6eedbc 100644
--- a/app-admin/clustershell/Manifest
+++ b/app-admin/clustershell/Manifest
@@ -1 +1,2 @@
+DIST clustershell-1.9.1.gh.tar.gz 383917 BLAKE2B 90d8c8390453a2c843bbb909a741d24d5f8e4b8eb03631bbe81b98973fce95d96dd3e68d0b951bc23d067057222c858e5041a3bafde200e0e2d14a0be995689f SHA512 32ee8b43d92e7ada8c81facc6a0609c39beee9189fa6fb9c2237387a58134f99fb2e6ab6e5de35c8e6fc8d3cef57f74f4c08b14968484546859071dff2594eb1
DIST clustershell-1.9.gh.tar.gz 382574 BLAKE2B 031eb9683db330f3b90ac06fa9a0409ea72c1be3d83c8d0519e0080ead715386043c925a6dbaeafdb38351c54f1508c050279603cd81bc2de60ba2df5733f636 SHA512 9eb4e9663a6381fa27311d1d70002ba64066ee6e2e08aaf772974d8097c6ca2d020563fc8478064e76bc6e56d37ed7eefc2919db99a2f5b26bd878fa7b764a15
diff --git a/app-admin/clustershell/clustershell-1.9.1.ebuild b/app-admin/clustershell/clustershell-1.9.1.ebuild
new file mode 100644
index 000000000000..a630103853a9
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.9.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://github.com/cea-hpc/clustershell/"
+SRC_URI="
+ https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-shells/pdsh
+ net-misc/openssh
+ sys-devel/bc
+ )
+"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+
+ # remove test sets that require working ssh connection
+ rm tests/{CLIClush,TaskDistant*}Test.py || die
+}
+
+python_test() {
+ cd tests || die
+ # Automatic discovery does not work
+ "${EPYTHON}" -m unittest_or_fail -v *.py || die "Tests failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+}