summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-25 05:13:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-25 05:13:39 +0200
commit3f1457f31319bc489655f703229b86a10d5531c1 (patch)
tree6facfe40e54175e36d3c4724e35277fdfd66ab10 /app-admin/awscli
parentdev-python/boto3: Bump to 1.35.48 (diff)
downloadgentoo-3f1457f31319bc489655f703229b86a10d5531c1.tar.gz
gentoo-3f1457f31319bc489655f703229b86a10d5531c1.tar.bz2
gentoo-3f1457f31319bc489655f703229b86a10d5531c1.zip
app-admin/awscli: Bump to 1.35.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.35.14.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index e5862a5f1ef1..bd159532defb 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,4 +3,5 @@ DIST aws-cli-1.35.10.gh.tar.gz 2811446 BLAKE2B 3151e107099821ffa3978d4a0175bf96a
DIST aws-cli-1.35.11.gh.tar.gz 2813001 BLAKE2B 8df6575c77783031d52ab99f34c90092bbb5ee67584b3a13bc29f4b171da08534f3851b2298074123e12ce8e43a2b7e98d812619652192ad5b1f97a8299f14b3 SHA512 8df319bb806233e5e32ef8bd07216b9e17966b49d5d3cb36c90bc92c7161120dc1e6434181920df62562e36dd2cc664d4b1e95e8ba953879488df25e56570bfc
DIST aws-cli-1.35.12.gh.tar.gz 2813508 BLAKE2B 817fc49d9225c7b5ef9aa95560138e348e872ecb46ea6be415d1b41d5989eec87ee3d9fdd265c0af2e28c2dba2e1a3e2e794a43d6cca170d639184b7cf3684cf SHA512 9f8fbb9c931d9b3c1d00e25e1018b2dbca7014a5946cf1f17155d18e47837218f8575e0e2a3cc64902d3b3baa8ada99f6e01a72f5fd74b209f807c646023c2c2
DIST aws-cli-1.35.13.gh.tar.gz 2814615 BLAKE2B ad59cfe26615902f2161b06f2ec5ffdfbad5e0ee15262a2b5d32cf4a2031afa1825c476d06cf072b190be6eab9991e7ce3f524c7864e52538726c3730bde07ca SHA512 4e23f8d64469f50b02858289387b5405474e292476b576f3f494a1efcec896abdfc0fd4f3b66423b13354628c81571f4be7152fbc9ed13de166f551386837b35
+DIST aws-cli-1.35.14.gh.tar.gz 2810216 BLAKE2B ea6de63fff9122dcd4eb47eb6cf45928321c69c6ac840b05a3183539b17e406c9056e2fcd60bdbfceb76a2ddc38844df93c80ccc9a507627c862059767b478c7 SHA512 bdb8397d02f77f8a7df37786027d6c26433a99ebc8947ffffb9f7775e75f0d926cf713686f07e7c996f4613d45e8277e6ecb2da5fb29109b023751188197e193
DIST aws-cli-1.35.5.gh.tar.gz 2808789 BLAKE2B 545c76bd349485fbf2dc5565317678904c99443e2e6dc2e12fa9de122327d8aa0e8b9579cec37afe2e949a0c31c48e0977e52d701ffc212182c692769c35a948 SHA512 2a9c86f1a63b657d3c95f8a65020ea7837ded9f5147ce31a535f59b9d9c1c91c3354a82286c25252da7d5b7c48c1898f594be0cb9e1ba54c6768133543fcba50
diff --git a/app-admin/awscli/awscli-1.35.14.ebuild b/app-admin/awscli/awscli-1.35.14.ebuild
new file mode 100644
index 000000000000..0fc6192a8587
--- /dev/null
+++ b/app-admin/awscli/awscli-1.35.14.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.y.(z+34)
+BOTOCORE_PV="$(ver_cut 1).$(ver_cut 2).$(( $(ver_cut 3-) + 34 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ case ${EPYTHON} in
+ python3.13*)
+ EPYTEST_DESELECT+=(
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ ;;
+ esac
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}