summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-19 05:13:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-19 06:27:45 +0200
commit309113afdf0053ab892ff659610e273c7d64fdbc (patch)
treeb6d57befbbfb5530caebf99e4d0c584c6f67d9f7 /app-admin/awscli
parentdev-python/boto3: Bump to 1.35.22 (diff)
downloadgentoo-309113afdf0053ab892ff659610e273c7d64fdbc.tar.gz
gentoo-309113afdf0053ab892ff659610e273c7d64fdbc.tar.bz2
gentoo-309113afdf0053ab892ff659610e273c7d64fdbc.zip
app-admin/awscli: Bump to 1.34.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.34.22.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 183dd14cb51b..2808d07b0240 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.34.14.gh.tar.gz 2790437 BLAKE2B df3355ac11561ac7f6e2a7c707d08de0b
DIST aws-cli-1.34.19.gh.tar.gz 2795240 BLAKE2B ede95bb83dffdef1cbc6896f35e6926e3f7fe1cf27a091c019a4edadc57c24a88d06900fc6542fcf78c21f57de6651759a8ebd44952b21864313269c1cbfb289 SHA512 a82299d7f2d2fbb4600c91739b38e22e83eb95ffae0e70ef62e95ba039de6a47ba1d4e2423190a5e8ee59bf768a85181153c60329b9bbfc1a3e794d07d50dc75
DIST aws-cli-1.34.20.gh.tar.gz 2795708 BLAKE2B 733b5fd765dcfdb04a6717efcdb78988f915bd4efbe90c862b2c08e26b3a79e4ccc075d3dfcb6ad475ecb10bb1c14f4f98ca459774a6ca58febb33b4d3d751fd SHA512 03b2a368940777aed9e12f1168de953144dad40f33f05ec506630df7145dcd9a51565b1e91d5561c20ec18705fdeb0360959a6c9d6ac5803a59da7a989279709
DIST aws-cli-1.34.21.gh.tar.gz 2796251 BLAKE2B c72399ae535ceaff6986be3d94956683a9cec868b7e0125b2c4f81f20a418a2dd926af3770caf5af70d915f76a4a1c367135075c9810a1274667a66f8dfaee6a SHA512 39d54dd1da183bf21fb2e22aa250bb05965c2dc04597eab7372a5af0de497bbd7c0d7084b38d12df8457fb22c74a2bd47bd32944f7269830a3dc34547f74af81
+DIST aws-cli-1.34.22.gh.tar.gz 2797222 BLAKE2B e9575e6f450daed3d45f9523cec74f8cd4a124a9cdb90e6abac1281efbc5df86463ccd47cf763891665765af67f22da6195bf4eadb77deb785ae759ad71f5563 SHA512 06f338559627035c24a029020dbbb58879c9101e3eb6b601b3783458135a0f86ae70ceaa4f3026c9a1b5e6af5d559b41f2eccc19895138374eb79c884fcf4cf1
diff --git a/app-admin/awscli/awscli-1.34.22.ebuild b/app-admin/awscli/awscli-1.34.22.ebuild
new file mode 100644
index 000000000000..599b9bd389b9
--- /dev/null
+++ b/app-admin/awscli/awscli-1.34.22.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}