summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-14 03:49:54 +0000
committerSam James <sam@gentoo.org>2023-02-14 03:49:54 +0000
commit2d14b011d128010337f1e0a7ff3a6b0ee9130c9d (patch)
treedce7a73f3d7532b7f3b2fe8cf0b485319f72e2cc /app-accessibility
parentapp-admin/apachetop: fix build w/ clang 16 (diff)
downloadgentoo-2d14b011d128010337f1e0a7ff3a6b0ee9130c9d.tar.gz
gentoo-2d14b011d128010337f1e0a7ff3a6b0ee9130c9d.tar.bz2
gentoo-2d14b011d128010337f1e0a7ff3a6b0ee9130c9d.zip
app-accessibility/espeak: fix build w/ clang 16
Closes: https://bugs.gentoo.org/894180 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeak/espeak-1.48.04-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-accessibility/espeak/espeak-1.48.04-r1.ebuild b/app-accessibility/espeak/espeak-1.48.04-r1.ebuild
index 083d363b1b10..b7da32ffabbc 100644
--- a/app-accessibility/espeak/espeak-1.48.04-r1.ebuild
+++ b/app-accessibility/espeak/espeak-1.48.04-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_P="${P}-source"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
@@ -46,6 +46,9 @@ src_prepare() {
}
src_compile() {
+ # Uses removed 'register' keyword, bug #894180
+ append-flags -std=c++14
+
emake \
PREFIX="${EPREFIX}/usr" \
CC="$(tc-getCC)" \