summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-02 22:19:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-03 16:03:31 +0100
commiteaf8e436e66469e47fe7f843997f1ca06021e467 (patch)
tree68a5c2077b0c80b1675a3f8b81f027a1e3de7d69
parentnet-im/pidgin: Drop 2.13.0-r3 (diff)
downloadgentoo-eaf8e436e66469e47fe7f843997f1ca06021e467.tar.gz
gentoo-eaf8e436e66469e47fe7f843997f1ca06021e467.tar.bz2
gentoo-eaf8e436e66469e47fe7f843997f1ca06021e467.zip
net-libs/libgadu: EAPI-7 bump, drop USE openssl and static-libs
Non-maintainer commit. Closes: https://bugs.gentoo.org/677502 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-libs/libgadu/libgadu-1.12.2-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-libs/libgadu/libgadu-1.12.2-r1.ebuild b/net-libs/libgadu/libgadu-1.12.2-r1.ebuild
new file mode 100644
index 000000000000..4083dad938d7
--- /dev/null
+++ b/net-libs/libgadu/libgadu-1.12.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Client-side library for the Gadu-Gadu protocol"
+HOMEPAGE="https://libgadu.net/"
+SRC_URI="https://github.com/wojtekka/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc ssl test threads"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-libs/expat
+ dev-libs/libxml2:2
+ net-misc/curl
+ )
+"
+DEPEND="
+ dev-libs/protobuf-c:=
+ sys-libs/zlib
+ ssl? ( net-libs/gnutls:= )
+"
+RDEPEND="${DEPEND}"
+
+BUILD_DIR="${S}"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --with-protobuf
+ --without-openssl
+ $(use_with ssl gnutls)
+ $(use_enable test tests)
+ $(use_with threads pthread)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( docs/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}