summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-15 03:16:26 +0100
committerSam James <sam@gentoo.org>2024-07-15 03:16:26 +0100
commitdb42acdc1613aa24dd34a480694e7eae7b43cdc0 (patch)
treed6da3460908a6233d8b7aff186ffa59101c2d09f
parentsys-block/thin-provisioning-tools: drop 9999 (diff)
downloadgentoo-db42acdc1613aa24dd34a480694e7eae7b43cdc0.tar.gz
gentoo-db42acdc1613aa24dd34a480694e7eae7b43cdc0.tar.bz2
gentoo-db42acdc1613aa24dd34a480694e7eae7b43cdc0.zip
sys-libs/minizip-ng: drop 4.0.4
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/minizip-ng/Manifest1
-rw-r--r--sys-libs/minizip-ng/minizip-ng-4.0.4.ebuild97
2 files changed, 0 insertions, 98 deletions
diff --git a/sys-libs/minizip-ng/Manifest b/sys-libs/minizip-ng/Manifest
index f08e2bb1b3de..81dbcc5c0b96 100644
--- a/sys-libs/minizip-ng/Manifest
+++ b/sys-libs/minizip-ng/Manifest
@@ -1,2 +1 @@
-DIST minizip-ng-4.0.4.tar.gz 770202 BLAKE2B 5b9f4a66325de4298db0f7cdb8830050fe55c46c3914f51d7e7c4fe4cd9e080ab9658739dc936da602d67199333b6eca71218ad155244b9c04f50944486a02b1 SHA512 2662ddf90666babe73474f6fc48f5a64f276d555b7a0f04f790b9edef570cb958356e900632c3795fb2053f4813c449240ff101d32b063eca4ad869bef0546fd
DIST minizip-ng-4.0.5.tar.gz 770078 BLAKE2B e9e416a8fae3c4e33c1fe644bbf4f3edf2becc8e8e0dfba079481c8c8fbd871c1591537c58e7aaa9b08ecee430c2acb8c1a5ee085fa8c819714fbe906876241e SHA512 760c540ccedd04c21d72ec7b41bc31a16e4291776580a6febb9400198440b3a64f39d4ba26be2608abf47b9dcc1ed266dad8bc0a8cacb607e4885c9dd05be0d6
diff --git a/sys-libs/minizip-ng/minizip-ng-4.0.4.ebuild b/sys-libs/minizip-ng/minizip-ng-4.0.4.ebuild
deleted file mode 100644
index d23ad9d63cb9..000000000000
--- a/sys-libs/minizip-ng/minizip-ng-4.0.4.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Worth keeping an eye on 'develop' branch upstream for possible backports,
-# as they copied this practice from sys-libs/zlib upstream.
-
-inherit cmake-multilib
-
-DESCRIPTION="Fork of the popular zip manipulation library found in the zlib distribution"
-HOMEPAGE="https://github.com/zlib-ng/minizip-ng"
-SRC_URI="https://github.com/zlib-ng/minizip-ng/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0/4"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="compat openssl test zstd"
-RESTRICT="!test? ( test )"
-
-# Automagically prefers sys-libs/zlib-ng if installed, so let's
-# just depend on it as presumably it's better tested anyway.
-RDEPEND="
- app-arch/bzip2[${MULTILIB_USEDEP}]
- app-arch/xz-utils
- dev-libs/libbsd[${MULTILIB_USEDEP}]
- sys-libs/zlib-ng[${MULTILIB_USEDEP}]
- virtual/libiconv
- compat? ( !sys-libs/zlib[minizip] )
- openssl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
- zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-cpp/gtest )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.0.4-libbsd-overlay.patch
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DMZ_COMPAT=$(usex compat)
-
- -DMZ_BUILD_TESTS=$(usex test)
- -DMZ_BUILD_UNIT_TESTS=$(usex test)
-
- -DMZ_FETCH_LIBS=OFF
- -DMZ_FORCE_FETCH_LIBS=OFF
-
- # Compression library options
- -DMZ_ZLIB=ON
- -DMZ_BZIP2=ON
- -DMZ_LZMA=ON
- -DMZ_ZSTD=$(usex zstd)
- -DMZ_LIBCOMP=OFF
-
- # Encryption support options
- -DMZ_PKCRYPT=ON
- -DMZ_WZAES=ON
- -DMZ_OPENSSL=$(usex openssl)
- -DMZ_LIBBSD=ON
-
- # Character conversion options
- -DMZ_ICONV=ON
- )
-
- cmake_src_configure
-}
-
-multilib_src_test() {
- local myctestargs=(
- # TODO: investigate
- -E "(raw-unzip-pkcrypt|raw-append-unzip-pkcrypt|raw-erase-unzip-pkcrypt|deflate-unzip-pkcrypt|deflate-append-unzip-pkcrypt|deflate-erase-unzip-pkcrypt|bzip2-unzip-pkcrypt|bzip2-append-unzip-pkcrypt|bzip2-erase-unzip-pkcrypt|lzma-unzip-pkcrypt|lzma-append-unzip-pkcrypt|lzma-erase-unzip-pkcrypt|xz-unzip-pkcrypt|xz-append-unzip-pkcrypt|xz-erase-unzip-pkcrypt|zstd-unzip-pkcrypt|zstd-append-unzip-pkcrypt|zstd-erase-unzip-pkcrypt)"
- )
-
- # TODO: A bunch of tests end up looping and writing over each other's files
- # It gets better with a patch applied (see https://github.com/zlib-ng/minizip-ng/issues/623#issuecomment-1264518994)
- # but still hangs.
- cmake_src_test -j1
-}
-
-multilib_src_install_all() {
- if ! use compat && use test ; then
- # Test binaries, bug #874591
- rm "${ED}"/usr/bin/minigzip || die
- rm "${ED}"/usr/bin/minizip-ng || die
- fi
-}
-
-pkg_postinst() {
- if use compat ; then
- ewarn "minizip-ng is experimental and replacing the system zlib[minizip] is dangerous"
- ewarn "Please be careful!"
- fi
-}