summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-11 11:30:11 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-11 11:30:48 +0000
commitc877f88cd66bad51839b501ea79e7fac892a85a7 (patch)
treee496fa3fe34a2984e5f1ba9d90e8fafce8cc12ae
parentapp-text/qpdfview: update mupdf dependency. (diff)
downloadgentoo-c877f88cd66bad51839b501ea79e7fac892a85a7.tar.gz
gentoo-c877f88cd66bad51839b501ea79e7fac892a85a7.tar.bz2
gentoo-c877f88cd66bad51839b501ea79e7fac892a85a7.zip
dev-java/itext: Adjust classpath and remove unexisting class with a patch. Fixes bug 557114.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-java/itext/files/itext-5.5.4-OcspClientBouncyCastle.java.patch15
-rw-r--r--dev-java/itext/itext-5.5.4-r1.ebuild56
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-java/itext/files/itext-5.5.4-OcspClientBouncyCastle.java.patch b/dev-java/itext/files/itext-5.5.4-OcspClientBouncyCastle.java.patch
new file mode 100644
index 000000000000..409ea87aa2bd
--- /dev/null
+++ b/dev-java/itext/files/itext-5.5.4-OcspClientBouncyCastle.java.patch
@@ -0,0 +1,15 @@
+--- source/com/itextpdf/text/pdf/security/OcspClientBouncyCastle.java.orig 2015-08-11 10:52:11.031000000 +0000
++++ source/com/itextpdf/text/pdf/security/OcspClientBouncyCastle.java 2015-08-11 10:52:39.070000000 +0000
+@@ -183,9 +183,9 @@
+ if (status == CertificateStatus.GOOD) {
+ return basicResponse.getEncoded();
+ }
+- else if (status instanceof org.bouncycastle.ocsp.RevokedStatus) {
+- throw new IOException(MessageLocalization.getComposedMessage("ocsp.status.is.revoked"));
+- }
++ //else if (status instanceof org.bouncycastle.ocsp.RevokedStatus) {
++ // throw new IOException(MessageLocalization.getComposedMessage("ocsp.status.is.revoked"));
++ //}
+ else {
+ throw new IOException(MessageLocalization.getComposedMessage("ocsp.status.is.unknown"));
+ }
diff --git a/dev-java/itext/itext-5.5.4-r1.ebuild b/dev-java/itext/itext-5.5.4-r1.ebuild
new file mode 100644
index 000000000000..9f7a091f6580
--- /dev/null
+++ b/dev-java/itext/itext-5.5.4-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library that generate documents in the Portable Document Format (PDF) and/or HTML."
+HOMEPAGE="http://itextpdf.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="AGPL-3"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/bcmail:0
+ dev-java/bcpkix:0
+ dev-java/bcprov:1.52
+ dev-java/xml-security:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="
+ bcmail
+ bcpkix
+ bcprov-1.52
+ xml-security"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-OcspClientBouncyCastle.java.patch
+)
+
+java_prepare() {
+ mkdir source || die
+
+ for x in *-sources.jar; do
+ unzip -n ${x} -d source || die
+ done
+
+ rm -v *.jar || die
+
+ mkdir target/classes/com/itextpdf/text/pdf/fonts -p || die
+ cp source/com/itextpdf/text/pdf/fonts/*{afm,html,txt} target/classes/com/itextpdf/text/pdf/fonts/ || die
+ mkdir target/classes/com/itextpdf/text/l10n/ -p || die
+ cp -r source/com/itextpdf/text/l10n/* target/classes/com/itextpdf/text/l10n/ || die
+
+ epatch "${PATCHES[@]}"
+}